Ford Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
771 Posts
Discussion Starter #1
My car use to run fine untill I did a Head/cam swap and converted to mass air. I have tried to fix this issue and still it happens, I cant get it to idle steadly. It starts and dies once or twice in the morning then drops down to 500 rpm stays there for 2 minutes then surges from 800-1300 rpm all day long.

1.I have rechecked all connection for the maf conversion its all good.

2. cleaned 10 pin connecters
3. Tried the idle reset in corral tech
4. got new Iab motor
5. cleaned tb
6. drilled hole in tb
7. cleaned maf electroics
8. got new act sensor

none of this stuff helped, Im at a loss here and want a nice idle to hear my TFS stage 1 chopping. the only other thing is that I have chrome valve covers with a push in breather not the one with the filter on it. Should I get the filter one and see if it helps?
 

·
Registered
Joined
·
771 Posts
Discussion Starter #3
anyone else..
 

·
Registered
Joined
·
481 Posts
There was a recent thread where they determined that their oil breather was the culprit - it caused too much air to get into the throttle body?? As I recall, they went back to the stock setup and that fixed that individual's surge. I know each case is different but you might want to research that one.

LOL
 

·
Registered
Joined
·
433 Posts
tps sensor try your friends easy swap if your problem is cured you know you need another one.

to bad you switched to mass air tfs stage1 cam idles smoothly with speed density and you would have went faster
 

·
Registered
Joined
·
25 Posts
With all those goodies I just don`t think you will ever be satisfied
with the idle or reach its full potential without a chip.Mine didn`t
 

·
Registered
Joined
·
1,176 Posts
The idle adjustment plate between the IAB and TB works great and is relatively cheap. F2PZ-9F939-A from Ford!
 

·
Registered
Joined
·
5,025 Posts
Syed, I told you in the PM how I fixed my surge. All I had to do was reset the idle and make sure the tps was no more than .95v koeo. Did u try using a reg stock oil cap?
 
1 - 9 of 9 Posts
Top