Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter #1
Had a chip burn today and not what I was hopping for.

259.6 HP

340.5 TQ

12.9 to 1 fuel ratio

I will try to post sheet but no luck so far
 

·
Registered
Joined
·
2,661 Posts
You need better heads(bigger). How much/kind of conv. are you running. You need to findout what is up with this, I will help as much as possible.

Good Luck, Greg(XSR)
 

·
Registered
Joined
·
5,780 Posts
wow, those are bad numbers... the 165 heads should flow more than just making close to 300hp....

take care,
adam
 

·
Registered
Joined
·
718 Posts
looks like it may be running rich also,maybe lean it out a hair
 

·
Registered
Joined
·
1,039 Posts
I'm guessing one or more cylinders (possibly 2) are not firing and/or have zero compression.

I'd double check the valvetrain setup--- run a compression test but honestly my guess is you have a valve hanging off a seat.


or...

vacuum leak(s)
majorly fubar'd timing

I would expect ~ 340 rwhp with that combo, at least
 

·
Registered
Joined
·
87 Posts
I agree with 93exchp, I made 300 rwhp with Track heat heads, intake, Anderson cam, and a stock shortblock. I have a bunch of other stuff like MAF and TB but you get the gist. I definitely think you have a valve hanging up or a compression problem. A friend of mine just made 362 rwhp with a 331, hand ported TFS heads and intake, and a small cam. I'd say you should be close to that. Nick
 

·
Registered
Joined
·
150 Posts
Discussion Starter #8
I just checked the base timing and he has it set to 8 degrees. The Gas is 93 Fuel pressure is 45 PSI, compression is 10.38.
I also found the vacuum line was off the EGR valve not sure if that make and difference. Car is also running around 200 degrees on the highway. around town its around 195

Do I need to upgrade radiator?
 
1 - 8 of 8 Posts
Top