Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
274 Posts
Discussion Starter #1
OK.... for the past week or so, ive been noticing a THUD coming from the left rear of my car when i give it a reasonable amount of torque...... shortly thereafter (as soon as the torque-load is taken off the rear the entire rear end kinda "wiggles" a bit. I think it wiggles to the right, but im not sure.

Here is my setup

FMS HD upper control arms and new Ford axle bushings

J&M (hotpart.com) lower control arms with poly bushings both sides

FMS "b" springs

stock sway bar

Ive put it up on the lift at work, and nothing is visibly wrong, or out of place at all, ive retorqued every bolt on the control arms, shocks, greased all the bearings etc...

Im at a loss:crying: :curses:


Thanks
 

·
Super Moderator
Joined
·
27,657 Posts
Get back under and make absolutely sure the UCA bushings aren't squishing out.
 

·
Registered
Joined
·
274 Posts
Discussion Starter #3
OK... I'm assuming you mean the one's attached to the body, what do you mean by "squishing out" ?
 

·
Super Moderator
Joined
·
27,657 Posts
No, I mean the ones on both ends just to be sure. By "squishing out" I mean that there have been several instances on here of the UCA bushings walking themselves right out of the arms or the axle, so they're not really providing any resistance any more and the axle is allowed to move.
 

·
Registered
Joined
·
274 Posts
Discussion Starter #5
well, i dont think that is the case, but ill check it out.... the upper arms are the FMS with the poured in bushings, not pressed.

thanks for the help though, this is irritating the fukkoutta me
 

·
Registered
Joined
·
911 Posts
i would have to say to check the uppers as well. any side to side movement or "wiggle" would have to be due to problems with the upper bushings. im curious to the exact "thud" sound. if upper bushings are bad the axle moves forward rotating upward when you hit the accelerator. this allows the D.S. to hit the tunnel under your car.........only other suggestion i have is to chack your toque boxes. both uppers & lowers. it could be torn away from the underside in some areas causing the noise as wel as the "wiggle" feel since your boxes lost rigitity. check the seems real good. you can also check the parking brake assembly where it mounts in your tunnel underneath. it can come loose causing some noises like you described & you could possibly feel a wiggle if the cables or assembly were dragging on the D.S. ........ how old are the uppers & lowers you have?
 

·
Registered
Joined
·
274 Posts
Discussion Starter #7
the entire rear suspension was just replaced, upper and lower control arms, including bushings have maybe 2,000 miles on them
 

·
Registered
Joined
·
911 Posts
check the things i mentioned in the above post, i cant think of anything else that would be possible..............
 
1 - 8 of 8 Posts
Top