Ford Mustang Forums banner
41 - 60 of 105 Posts

·
Registered
Joined
·
2,547 Posts
It hasn't run right since before the original injectors. I pulled the original injectors to see if any were bad. I had them tested and they were fakes. Surprisingly enough; the car ran well with the fakes.
I did have issues with backfiring when getting into boost or possibly just higher rpm's?
Swap the two injector plugs.
 

·
Registered
Joined
·
2,547 Posts
If both 5 and 6 are acting up; what will swapping their injector plugs tell me?
You repinned some of the 60 pin connector right? Some of which were fuel injector pins. Maybe they got switched.
 
  • Like
Reactions: Dwain

·
Registered
Joined
·
4,529 Posts
Discussion Starter · #45 ·
You repinned some of the 60 pin connector right? Some of which were fuel injector pins. Maybe they got switched.
I ran an injector pulse test with Tuner Studio twice. The correct injector clicked each time.
 

·
Registered
Joined
·
2,547 Posts
I ran an injector pulse test with Tuner Studio twice. The correct injector clicked each time.
Do you have a video of it running right now with the issue? If fuel is getting there, spark is happening, and compression is good that really only leaves limited options as to what may be wrong.

There could be something in the valvetrain, but I’d expect it to have made some type of noise before knocking out 2 cylinders - if that is the issue.

I have the video of when you got the car running initially, and everything sounds good. So at one point everything was fine.
 

·
Registered
Joined
·
4,529 Posts
Discussion Starter · #47 ·
Do you have a video of it running right now with the issue? If fuel is getting there, spark is happening, and compression is good that really only leaves limited options as to what may be wrong.

There could be something in the valvetrain, but I’d expect it to have made some type of noise before knocking out 2 cylinders - if that is the issue.

I have the video of when you got the car running initially, and everything sounds good. So at one point everything was fine.
I can take a video but it's difficult to hear the misfire. I feel it more when sitting in the car as it idles. If I give it a bit of throttle; it stumbles. I've driven it down the street and it lightly backfires every so often. It's not a loud backfire at all. I have a new set of DUI plug wires to try tomorrow. I don't trust these Ford Racing ones. Also; that previous video of it running good was with the new 60 pin plug re-pinned.
 

·
Registered
Joined
·
1,471 Posts
I will ask my usual question I seem to ask when mysterious problems arise on an EFI SBF. And it seems like I've asked this question a half dozen times this year. What brand cap and rotor?
 

·
Registered
Joined
·
4,529 Posts
Discussion Starter · #49 ·
I will ask my usual question I seem to ask when mysterious problems arise on an EFI SBF. And it seems like I've asked this question a half dozen times this year. What brand cap and rotor?
I believe it's Motorcraft but I won't swear to it. I started this project in the winter of '19 and bought a lot of parts back then. My memory isn't what it use to be. What was the question? 😀

Also; the car ran fine with the current cap and rotor before the trouble started.
 

·
Registered
Joined
·
4,529 Posts
Discussion Starter · #51 ·
If the pick ups and terminals on the cap are the aluminum/zink type should get another cap and rotor kit with all brass terminals/pick ups.
I only buy brass. I checked for wear and carbon tracking. The cap still looks new as does the rotor.
 

·
Registered
Joined
·
4,529 Posts
Discussion Starter · #53 ·
As you guys can tell; I've covered a lot of ground in the last 2 weeks. Lol.
 

·
Registered
Joined
·
96 Posts
Really cool seeing so many people trying to help someone out. And, all the suggestions help me understand the trouble shooting process/peoples train of thought on the 34 year old car sitting in my garage.
This is the reason I joined Corral. Not trying to be a suck ass, but credit where credit is due.
 

·
Registered
Joined
·
1,471 Posts
I used to do the same with brake rotors.
Yeah same here with Autozone clutches lifetime warranty beat the hell out of them in my mild build hci 308 and never any questions asked bringing the old burnt out clutch back just hand me a new one over the counter after giving them my phone number no questions asked.
 
41 - 60 of 105 Posts
Top