Ford Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
556 Posts
Discussion Starter #1
I just swapped out my cobra intake for a TFS track heat. I started it and it would barely run. My vaccum guage wasnt moving at all. Stuck at 0. I connected my PVC to the hole in the upper plenum on the drivers side. I plugged three of the four holes on the under side middle of the upper plenum. The fourth hole I connected to the canister thing. I am using an intake elbow adapter. The hole in it i have connected to everthing else like vaccum tree, egr, blower bypass, map sensor, fuel pressure regulator, and FMU. I have a plug in the lower number 5 runner also. Is there any other vaccum connections I didnt see? My intake didnt come with directions and ive looked on the trick flow website but I dont see what i missed. Any help or ideas on what to check?
 

·
Registered
Joined
·
556 Posts
Discussion Starter #2
who has put a TFS street or track heat intake on their 94/95?
 

·
Registered
Joined
·
563 Posts
i have the track heat on my car, however i don't know much about the blower part of your car. on my car, the pcv hose goes to two different hookups. the one you were talking about on the drivers side and on underneath the intake. i had four holes underneath my intake and i only plugged two. i use the same adapter elbow as well, i hooked up the egr to it, the vacuum tree, fuel pressure regulator and all of the cables to it. other than that, i really don't know. are you sure that hooked up the green hose to the egr and the red hose to the vacuum tree? that is the only thing that i can think of that might be switched or something. look your overs real good and if you have any questions let me know and i can look at mine. i'm in the process of putting heads on my car right now, so it's in a few pieces, but i left alot of stuff still hooked up plus i think i remember most of it, i just installed that intake about 3 weeks ago, and i just pulled it back off yesterday! hope this helps you out.
 

·
Registered
Joined
·
556 Posts
Discussion Starter #5
I feel stupid. It was just timing :eek:
 
1 - 5 of 5 Posts
Top