Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,291 Posts
Discussion Starter · #1 ·
I have been trying to chase this problem down for a year, when the car is in gear it will not idle at a stop light,etc but when it is in P or N it will idle fine. Here are the mods:
Trick Flow street intake
E-303 cam
70mm tb
75mm Pro Flow MAF
K&N filter
C&L true flo inlet pipe
Taylor plug wires
bbk headers
mac prochmaber
flowmaster cat back
373 gears
transgo shift kt
alum d/s
Had a diablo chip
MSD 6A and coil

Had the motor pulled to replace the oil pan gasket and had the heads freshened with a valve job and the idle problem happens with or without the chip in it. I have checked the tps voltage and it is okay, replaced the 02 sensors and the senor I think is called the ECT with a ford one, the idle problem was there before most of the mods and I cannout figure it out. Would the distrubutor cause this? Help!
Greg
 

·
Registered
Joined
·
3,249 Posts
If it is not idleing in gear, then could possibly be the torque convert has gone bad. I had a 67 Mustang and the torque convert went bad, stayed locked up, had not stall. Had to raise the idle to at least drive it. Does your torque convert stall or at what rpm does it lock up? What is your idle set at? Just throwing bones out.
 

·
Registered
Joined
·
1,291 Posts
Discussion Starter · #5 ·
The idle at P/N is at 900-1000 whcih I raised to try to keep the car running. trying to achieve a higher idle witht eh car in gear. It will idle for a second or two and then it starts chugging and the battery gauge twicthces like crazy with the idle of the motor. Put it in N and it idles fine?????????????????????
 

·
Registered
Joined
·
1,291 Posts
Discussion Starter · #6 ·
Today I swithced from a mac off road to a prochamber and changed out both 02 sensors, could thos have been bad and causing my idle problem?
Greg
 

·
Registered
Joined
·
3,249 Posts
Did it not idle before you changed to the prochamber and change the O2's? If so, then that could be your problem.
 

·
Registered
Joined
·
1,291 Posts
Discussion Starter · #8 ·
I just took it for a quick test drive, and I am throwing a code, I will have to have that read. Just wondering if anyone had any 02 experieicnes that caused their car to idle badly.....
 
1 - 8 of 8 Posts
Top