Ford Mustang Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2,740 Posts
Discussion Starter #1
My mustang has serious problems idling, I have had this combo for about a year and no problems, I have no codes, but I replaced the IAC, EGR, EGR pos sensor, TPS or whatever its called. If there is a code lurking in there will disconnectiong the battery clear it? It does seem like there is slight power loss maybe im just imagining and it just sounds different at idle I dont know, like its loping alot more, I never used to have these problems. Sometimes its fine, and other times it surges dies when I turn with the clutch in its like its posessed. I cleaned out the throttle body, and ran fuel injector cleaner through it, the injectors only have a few 1750 miles on them as well as the TB the bottom end has 62000 miles on it no smoke besides brownish black (slight) at WOT. Oh I do have a fuel pressure reg set at 41 psi.
 

·
Registered
Joined
·
1,626 Posts
Who hasnt experienced that? Seems like every 94-95 has this problem sooner or latter, specially when modded. Today i got to talking to this guy at a car show.. he had a 95GT 347, all motor.. anyways, i got to asking him if he has experienced the surging and rough idle. he said yes.. he got a Johnson chip, still didnt clear it up, but helped.. the he said the guy that did the tune, drilled a small hole in the throttle body butterfly/blade.. and then unbplugged the IAC.. and it fixed it. Im going to try to hole in t/b blade, and see if that doesnt fix my problems.
 
1 - 2 of 2 Posts
Top