Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter #1
hey i was driving home last night (97 cobra) and while pulling out of the parking lot my clutch had a VERY light vibration while engaging and disengaging the pedal...Then, as I came to a stop, a light squeeling like my belt slipping started...Light turns green and the squeeling stops...I pull into my place the squeeling now is happening while driving very slow through my neighbor hood, I rev the motor up, the squeeling stops...The clutch also seemed to get more and more mushy as I got home...The squeeling is VERY loud while ideling and not in gear...I push the cltch in and the squeeling somewhat goes away...The clutch grabs fine, no slipping, etc. And I was driving normally, no racing or anything. What could it be? Would a bad belt cause my clutch to act funky? Low on fluid? If so where is the reservoir to check? Bad clutch? etc? Any help is appreciated...
 

·
Registered
Joined
·
267 Posts
Discussion Starter #2
ok, i just went and started it...its definetly not anything to do with the belt...the clutch was VERY hard to push in at first, started it up, and a LOUD whine came from somehwere and continued...I pushed the clutch in and it quited a little bit, but not much...it got a little easier to engage and disengage, but it was still quite a bit harder than usual...all the gears go into place, just makes a loud shrieking noise and the clutch is tight...any help???
 

·
Registered
Joined
·
3,557 Posts
eh...so the noise goes away when you push the clutch in? maybe your throwout bearing...
 

·
Registered
Joined
·
267 Posts
Discussion Starter #4
it doesn't fully go away...it gets quite'er, but doesn't go away...plus the clutch is hard to push in...
 

·
Registered
Joined
·
657 Posts
Its the TO bearing... for sure , usually they almost completely go away with the pedal in however. Idle they are noisy!

i have this go bad on every damn mustang i own .. sure is annoying!
 

·
Registered
Joined
·
267 Posts
Discussion Starter #6
yeah it was the throwout bearing...it was loud no matter the clutch was in or out, got some balls and drove it to a friends house to fix it and the sound went away all except idle...
 
1 - 6 of 6 Posts
Top