Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,409 Posts
Discussion Starter · #1 ·
So i've changed so many things already (Dizzy, TFI, IAC, ECT) and set timing to 14* but still have a surging idle only on startup. After about 2-3 mins, it is running just fine and holding still around 750-800 rpms.

I have no EGR (used block off plate) and even did that EGR valve mod where you remove the plug from the whole valve assembly and then push the pin 1/2 way and connect the valve back to the harness and it made no difference.

Thoughts as to what this might be now?

After the 2-3 mins its all good.
 

·
Registered
Joined
·
2,433 Posts
So i've changed so many things already (Dizzy, TFI, IAC, ECT) and set timing to 14* but still have a surging idle only on startup. After about 2-3 mins, it is running just fine and holding still around 750-800 rpms.

I have no EGR (used block off plate) and even did that EGR valve mod where you remove the plug from the whole valve assembly and then push the pin 1/2 way and connect the valve back to the harness and it made no difference.

Thoughts as to what this might be now?

After the 2-3 mins its all good.
The IAC valve may be the problem. As the engine warms less fuel is added which requires a changing air flow. If the IAC is stuck or is sticking idle surge will occur.
 

·
Registered
Joined
·
615 Posts
I had the same problem with my car, had pretty much everything new and good ignition system.
I read a lot about it and no one could ever tell me what the problem was besides, get a tune.
I've heard that its good to keep the IAC a little dirty cause a new one causes this problem, well I didn't want to put a old one on, so i bought an IAC adjuster plate, and boom, it worked.
 

·
Banned
Joined
·
1,228 Posts
wow .. I am having this same problem .... plus a long crank time .. maybe the iac adjuster will fix mine
IAC adjuster is a bandaid fix... find the source of your problem.. dont just cover it up.

Long cranking time and rough start up can be attributed to larger than stock injectors as well. If the car is not tuned for them, it can cause issues.

Reason: The car does not read the maf for the first 15-20 seconds of startup. It reads off a Injector PW at Cranking table. If your car is supposed to have 19# injectors and you have 30# injectors, you are supplying roughly 36-38% more fuel while cranking, which can wet plugs, cause studdering, and poor idle on initial startup.
 

·
Registered
Joined
·
13 Posts
mine is stock the big prob with mine is that it was a v6 car that was swapped to a gt with a full gt drivetrain and IC im tlakin engine trans rear harnesses all of it but i got it when they were half ass thru it and am tryin to make the car right again lol for some reason the speedo reads fast but the gears seen like 327 when i count it out did the v6 cars come with a 3.08 gear in em? if so i need to check the color of the speedo gear and see if its the original v6 speedo gear or since i got a set of 4.10s i may just get teh correct gear for that and swap it all at once and see if that cures my problem in the speedo dept. but back to the inj mine are stock the maf is stock timing at 14 degrees etc. typical stuff nothin major
 
1 - 6 of 6 Posts
Top