Ford Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
906 Posts
Discussion Starter #1
Just got back from Cedar Falls Raceway. First time running at a 1/4 mile track ever, so it was a little to get used to. The BFG's would not hook very well at all. I was talking to a guy that used to run them and he said they don't hook worth a crap until they're worn down a ways. It was pretty funny cuz just as were leaving the track he takes a look at the tires and says,"Yep, a few more passes and these things will just be gettin ready to hook." I was just like..."great.. :rolleyes: " Oh well, they'll hook that much better next time.


Well anyways I ran a ton of 12.9's and 12.8's. But my best was a [email protected] There was a 99 WS6 running 12.9's with an LS6 intake, LS6 cam, exhaust and bolt-ons. So yea, the mph is there. I just need to learn how to hook up better with the tires. I'm pretty happy with the times, but mostly the mph because that lets me know there's a lot more in it. I still need to learn where to shift, I'm thinking about getting a shift light and hiding it in the heater vent. Oh, the car weighed 3325 with me in it. I weigh 160, so I should be able to get it down closer 3000 (w/o me) with some drag wheels and more weight reduction. My buddy said he dropped 60lbs with just the Welds. Well, here's the slip...

 

·
Registered
Joined
·
477 Posts
Nice times, and did you get the BFG's real hot before you tried to hook with them??? They need to be heated up with a good burnout before you dump the clutch
 

·
Registered
Joined
·
906 Posts
Discussion Starter #3
Yea, I tired but they just wouldn't hook too well. Part of that is inexpierance and part is that the tires are brand new. Another guy that used to run those tires was telling me they're just about to the level where they'll start hooking, so maybe next time with some practice I can hook up better.

Jake
 

·
Registered
Joined
·
3,207 Posts
that is good MPH. Let us know how the future runs are.
 

·
Registered
Joined
·
709 Posts
what was wrong with that ws6. Those things can be made to run 13.0-13.1 stock. He should have been way faster???
 

·
Registered
Joined
·
784 Posts
Most LS1's do not run low 13's stock, only a few do... BTW, your car hooked up pretty good with the 1.8 60 foot. My friend has a Z28 with similar mods, 4.10's and nitto drags and the best 60 foot time he's got is 2.0 . His best et is 12.9 at 109.5mph
 

·
Registered
Joined
·
38 Posts
wow- makes me think i drive my car like crap with a 111 mph and 112 mph and only a 12.8!!!!!!

i need to learn how to launch too. 1.9 is my best on nitto's.. nice times.
 

·
Registered
Joined
·
429 Posts
46callaway said:
Most LS1's do not run low 13's stock, only a few do... BTW, your car hooked up pretty good with the 1.8 60 foot. My friend has a Z28 with similar mods, 4.10's and nitto drags and the best 60 foot time he's got is 2.0 . His best et is 12.9 at 109.5mph
yea a friend of mine just sold his 99 TA and bought a brand new z06... the TA was an auto, all it had was LT headers, offroad pipe, and SLP loudmouth catback, loud as hell...and a K&n system... ran a 13.2..there were stock ones with LS1's running in the 14s!!! new drivers i guess.
James
 

·
Registered
Joined
·
753 Posts
Most of the stock LS1s at my track run high 13s to low 14s. :confused: who knows?

Great times, bullitt_stang!
 
1 - 14 of 14 Posts
Top