Ford Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
When I installed my Autometer water temp gauge, I removed the factory sending unit from the intake and placed the new sensor there. Since then I decided to revive my dead factory gauge. To do this, I picked up a FRPP water neck which has a threaded hole in top that I read would accept the factory temp sending unit but it will not thread into it. Just looking, there is no damage to the threads and they appear to be the same. Is there something I'm overlooking? Do I need some type of adapter? Have any of you run into this? Any help is appreciated..........STEVE
 

·
Registered
Joined
·
126 Posts
Discussion Starter #2
Anyone?

Is any of you running an aftermarket temp gauge and still have the factory temp gauge hooked up? If so, how did you do it?
 

·
Registered
Joined
·
3,013 Posts
You need a brass fitting from Pep Boys...
 

·
Registered
Joined
·
126 Posts
Discussion Starter #4
drudis said:
You need a brass fitting from Pep Boys...
drudis, thanx for the pic and the reply. The brass fitting shown in the pic now houses my Autometer sensor. Are you saying that I also need that fitting for the FRPP water neck? I had not thought of that.........Thanx....STEVE
 

·
Registered
Joined
·
743 Posts
If you have an aftermarket and still want the stock one, could you splice into the wire off the sending unit for the new one and run em both that way?(Im about to install the guage)
 

·
Registered
Joined
·
126 Posts
Discussion Starter #6
No, I cant because my Autometer is a mechanical gauge. My problem is solved if I can find a way to thread the factory sender into the FRPP water neck. To make this more strange, I went to hardware store yesterday, picked up a female x female brass connector. The plug from the water neck and the sender will both thread into the connector but the sender will not thread into the water neck. This just doesnt make sense to me......STEVE
 

·
Registered
Joined
·
126 Posts
Discussion Starter #7
No luck......

Well, I give up....after three auto parts stores, three hardware stores, Lowes and Home Depot and multiple speed parts catalogs I have found nothing.
drudis, tried your idea, but that fitting will not thread into the water neck nor will the sender thread into that fitting...............Thanx guys for the replies.....STEVE
 

·
Registered
Joined
·
355 Posts
Darius, if you don't mind, what is the size of that fitting? Does the Autometer mechanical water temperature gauge fit right in it? Thanks, I am having trouble finding the proper fitting.
 

·
Registered
Joined
·
3,013 Posts
I know that the "nut" part (the fitting ABOVE the sensor) is a 16mm 1.5pitch thread. I had a hard time sourcing this to weld a bolt-nut onto the oilpan for the oil-temp sensor.
The brass for the intake shouldnt be _that_ hard to find, the STEEL NUT was!
 
1 - 9 of 9 Posts
Top