Ford Mustang Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
1,980 Posts
Discussion Starter #1
Me and Dave (Willrace4food) were driving on the highway last night. Just cruising around maybe 70mph prob 2000 rpms. All of a sudden i get this loud repeating clacking noise that got faster with RPM. It did this for about 10 seconds than suddenly stopped. At first i thought i broke a valve spring. I drove the car home about 10 mins away. The car would hold idle, but there was a VERY big loss of power. I would half to give it atleast half throttle for the RPMS to go up at all. We popped the hooded while it was at idle and at the passenger side you can hear what it sounded like one of the pistons wasnt firing. Sounded just like air pumping or something. I pulled the passenger side valve cover and everything was intact. I also pulled the passenger side plugs and those were fine. The car hasnt seen nitrous since october. The motor has approx 110kmiles on it, so i think it was just tired. I am going to be doing a compression test and pulling the other valve cover as soon as i get a compression tester. I think its the motor but not 100% sure. But with the sound i heard, and the loss of power thats the only thing i can think it is. Now i gotta start saving for a new shortblock most likely. :( If anyone is looking for a NOS NOSzle kit i will be selling it very cheap. This was only installed on the car for 3 weeks. I need $$ badly.

Dave
 

·
Registered
Joined
·
30 Posts
Sounds like you need an '03 Cobra! I hope ends up bing something simple.
 

·
Registered
Joined
·
1,980 Posts
Discussion Starter #3
From the noise we heard and the way it was running i do not think its something simple. :( Car was hesitating and bucking very badly, and absolutely no power. I wish i can afford an 03 Cobra, but i still owe on my GT :(
 

·
Registered
Joined
·
2,335 Posts
that sucks, but with those kind of miles and spraying I think it was do for a retirement. Hey I bet SD has some nice short blocks laying around... Now you can get some forged internals. Let us know what the failure was. My guess is its a spun bearing from your description.
 

·
Registered
Joined
·
1,805 Posts
Wow Dave. Sorry to hear of your engine's demise, but you seem to have a good outlook. It's an opportunity to make it stronger.
 

·
Registered
Joined
·
1,821 Posts
Sorry to hear about the motor. You know if money is a real issue you may just want to look for a used 96-98 short block you can swap in. Then if your block is okay go ahead and use it for a build up in the future as you have the cash. That is my plan if anything happens during the race season. I have 94K very hard miles on my car.

Bill
 

·
Registered
Joined
·
429 Posts
man, that sux...good luck in whatever you find.

it seems like once these motors want to go....nothings gonna stop it...like theres no in-between.. just a big ka-boom...

i hope mine wants to stay together for a bit more...
 

·
Registered
Joined
·
645 Posts
Hey Dave....

bright side to all of this...IT HAPPENED IN THE DEAD OF WINTER!!!! So it could definitely be worse!!! I'll call you later about going up to Dez's next week
 

·
Registered
Joined
·
642 Posts
sorry to hear about that dave. I have been down that road before and it is not fun
 

·
Registered
Joined
·
3,173 Posts
Thats too bad, Dave. Sorry to hear about that. Let us know what the problem winds up being, and what you're gonna do about it. Lets hope it wasn't the spray that weakend the pistons.
 

·
Registered
Joined
·
1,980 Posts
Discussion Starter #14
Well thanks for all the support and suggestions guys. Bill i actually have a 99 shortblock in my garage. I bought a complete longblock and used the heads from that. The way things are looking now i am most likely going to be going with a forged shortblock with low compression. Im going to use the 99 windsor block i have and buiild off of that. This depends on if i can come up with the $$ somehow.

As far as what is actually wrong with the car im not 100% sure but i do think it is the bottom end. I do not see it being a valve spring, and i cannot think of anything else that would make the noise that it did and cause it to run how it did. Someone mentioned a bad coil pack but i doubt it. I will not be sure until i tear it down to see what lies beneath those heads. Hopefully i can get to it this weekend and i will let you guys know what i find. Thanks for the help.

Dave
 

·
Registered
Joined
·
1,462 Posts
Dave,

Bill has a good point. We could have that 00 block installed and running VERY soon. Now if you decide to go with a built block, you know it's going to be down for quite a while.
 

·
Registered
Joined
·
1,980 Posts
Discussion Starter #16
willrace4food said:
Dave,

Bill has a good point. We could have that 00 block installed and running VERY soon. Now if you decide to go with a built block, you know it's going to be down for quite a while.
Yes it is going to be down for a while. But i did some convincing and i was able to borrow a car. To top it off it will be fun to drive. Atlantic Blue 98 GT vert until my car as fixed :D Besides the car being BONE stock its a mint car, and i wont have to worry about as bad of gas mileage :lol: :lol:
 

·
Registered
Joined
·
1,949 Posts
Dave,

Sorry to hear about the potential loss.... if you find yourself in a jam I have a 60K mile motor in my garage.
 

·
Registered
Joined
·
1,821 Posts
Dave, looks like I'm a bad situation now as well my trans decided to give me problems tonight and don't expect it to last much longer So now I have to decide to either spend most of the money I saved for a truck on a TKO set up or what I'm going to do.

Bill
 

·
Registered
Joined
·
1,980 Posts
Discussion Starter #19 (Edited)
Bill sorry to hear about your tranny. I had 2 T-45s crap out on me before i decided to step up to a Tremec. Yours lasted pretty well from the abuse and the amount of track time it saw. and to top it off its a daily driver no less. i meant to ask you, do youdrive your car to the track. And if you do, if it breaks how do you get it back? I had to get AAA plus just in case lol. I broke twice at the track 120 miles from home :eek: But thats the game ya know. I have a 92 Probe that needs a tranny i was thinking about fixing to drive around. So i have to decide if i want to fix that so atleast have a car, or fix the stang. For the next few weeks i have a car to drive so its not a problem. Goodluck with your situation.

Dave
 

·
Registered
Joined
·
1,821 Posts
Yes I do drive it to the local track it's only about 30 miles away and also AAA comes in handy from time to time. ;) I've had to be towed home twice, once from the broken differential and again when I twisted the axle housing. I also drive the car to most of the FFW and NMRA events I attend but was hoping to get an early model F150 next month to tow it to events. Now however instead of having $4000 to spend on the truck I think I'm going to get the TKO put in and just finance something...not how I wanted to do it... Like you said though I can't complain I got 94K miles out of it and over 600 passes beating the living hell out of it, not too many can say that.

Bill
 
1 - 20 of 20 Posts
Top