Ford Mustang Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1,087 Posts
Discussion Starter #1
I finally got off my butt and installed my King Cobra clutch, Mac H-pipe, FMS Aluminum driveshaft and MM K-member Brace. Everything went on pretty easy. We replaced the rear main seal while we were in there also. The driver's side of the H-pipe needed some extra elbow grease and the Aluminum driveshaft needed an extra shove to line up properly but all in all the install was pretty straight forward.

The car sounds awsome. The clutch chatters a bit but so did my buddy's when he installed it. The chatter went away after a month of use on his car so I'm expecting the same. It only happens on take off anyway. Has anyone else experienced this?

While we had all these parts off the car we also welded up the e-brake cable bracket that had halfway broken off and was rubbing on the stock drive shaft. That went up no problem and we threw some paint over it to keep it from rusting. However now the ebrake cable sticks. When I disengage the e-brake and go to take off its like the emergency brake is still engaged. What a paint.

Also i am now hearing a clunking coming from underneath the car near the tranny area. I'm thinking the wider driveshaft is hitting the h-pipe somewhere. Also my water pump gasket is leaking... GRRRR... too bad now the bug has i have a feeling my pockets are gonna be getting alot lighter...

I love the sound of a cat-less stang!
 

·
Registered
Joined
·
2,073 Posts
When you took the old cluch out did you have the fly wheel turned? When I replaced the cluch in mine the first time I didnt have the flywheel turned and it did the same thing on take off. It did smooth out after a little driving but it was always there if only a little. As for the other issue I dont know, I'm still new at some things, have fun.
 
1 - 2 of 2 Posts
Top