Ford Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6,395 Posts
Discussion Starter #1 (Edited)
hello

I need help troubleshooting this 95 cobra. thansk in advance...

The motor idles rough and misses. And sometimes it dies. I might of set my timing wrong because

This is how I set it up..
cyl # 1 tdc
crank key way facing up
and rotor poiting towards cyl #1 valve cover

I think im way off :eek:


please help
 

·
Registered
Joined
·
6,395 Posts
Discussion Starter #2
I managed to get the timing at 10 BTC without the spout connector. But the distributor seems to be way off from its original position.

I'm not sure if this means anything......
 

·
Registered
Joined
·
949 Posts
try this....pull #1 plug...crank it over by hand til it pisses air, your at TDC..look at your balancer, you should be at zero or close...if close than tweak it to the zero...pull the dist up and drop it back in. make sure the rotor is directly under #1 on the cap, ( the rotor should be pointing to the firewall) if not than lift the distributor and move it over a tooth or 2, drop and rotate it back in, see if its over #1 on the CAP.....
harder to explain than it is to do....good luck..
 

·
Registered
Joined
·
6,395 Posts
Discussion Starter #4
RIO 5.0 said:
try this....pull #1 plug...crank it over by hand til it pisses air, your at TDC..look at your balancer, you should be at zero or close...if close than tweak it to the zero...pull the dist up and drop it back in. make sure the rotor is directly under #1 on the cap, ( the rotor should be pointing to the firewall) if not than lift the distributor and move it over a tooth or 2, drop and rotate it back in, see if its over #1 on the CAP.....
harder to explain than it is to do....good luck..
I got it thanks
 
1 - 4 of 4 Posts
Top