Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
718 Posts
Discussion Starter #1
Hey guys, I'm fighting with a ghost miss in my car. I know it has to be electrical. Can any knowledgeae guys maybe help me out here. Would be easier to talk on the phone as its a long story... Short story is that I'm getting fire and fuel but 2 cyl aren't working. Nothing should be wrong with the motor as it was running fine a week ago when I took the trans out. I extended/hid some wiring and I think that's where my problem is
 

·
Registered
Joined
·
1,031 Posts
I'm getting fire and fuel but 2 cyl aren't working...
I presume by "fire and fuel" you mean the cylinders in question are getting spark and fuel. Is this correct?

Or have you actually determined that there is no spark or injector control going on for the two cylinders in question? For example, you've pulled the plug, grounded it and cranked the engine and seen no spark; you've put a stethoscope to the injectors and hear to ticking from them while cranking.

If you have spark and fuel to the two cylinders, do a compression test.

If you are missing one or both, open up your wiring modifications and start looking for mistakes.

What year is the car?
 

·
Registered
Joined
·
718 Posts
Discussion Starter #3
It's a 2000 car but the motor is an 08 5.4 4v. I have done all that you just asked. Listened to injectors, checked fire by grounding plug, switched coil packs and injectors. Put a noid light on injector plug. I'm about to do a compression test
 

·
Registered
Joined
·
718 Posts
Discussion Starter #4
I didn't test all 8. I can if need be. But the passenger side bank was 165,170,175,170. And the last 2 are the problem cylinders. The plugs were soaked on those 2 cyl also.
 

·
Registered
Joined
·
1,031 Posts
It's a 2000 car but the motor is an 08 5.4 4v. I have done all that you just asked. Listened to injectors, checked fire by grounding plug, switched coil packs and injectors. Put a noid light on injector plug. I'm about to do a compression test
What were the results of all of this?

Do you have spark on all 8?

If the plugs are soaked, assuming it's fuel wetting them, then the injectors on the problem cylinders are working.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #6
I feel like a moron. And I swear I tried this yesterday. But, I switched 2 coil pack wires and it cured it. I must have switched the wrong ones yesterday in my aggravation. Car runs smooth. Not making as much boost as it was before but I can figure that out. Thanks for your help anyways man!
 
1 - 6 of 6 Posts
Top