Ford Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey people i have a question on the mach 460
so i know how to wire up the harness on the head unit
im having trouble with the amp plugs
the previous owner cut up most of the stock amp wires so right know theres wires pretty much loose every where and i has wonder if any body has a simple solution on how to wire them up just to make the amps work with my head unit
so i could get some bass
im tired of just listening to my tweeters its so fustrating
please help me out.......
i'll post some pictures later.....
 

·
Registered
Joined
·
797 Posts
this thread should be in the car audio section

If you are using an aftermarket head unit with the factory amps it wont sound as good as the factory radio using the factory amps, so if you have an aftermarket head unit you should just run new wires to the speakers or get a 4 channel amplifier, RCA cables, and some 16 gauge speaker wire

i did an amp install on my car and after i was done it sounded amazing.

speakers Infinity KAPPA680.9CS new from Ebay $115 per pair
RE Audio XTX-800.4 (XTX800.4) 4-Channel Digital Amplifier
Belva BAK82 8 Gauge Amp Wire Kit with 2-Ch RCA Cable

here a few pics of my install



 

·
Registered
Joined
·
530 Posts
Mach 460, Mach 1000 Audio Upgrade, Wiring Diagrams - MustangSpecialties.net

Does this help.
I know mine was messed up when I got it. I put and aftermarket headunit in and bought a special harness adapter I think MEta or something like that. It sounds good enough for me now.
I guess the mach 460 uses some weird OHM rating that is not compatible with other amps or something of that nature. Thats why just putting in just aftermarket speakers doesn't work and just putting in aftermarket amps doesn't work either, you have to do the whole thing. Like I said, mine sounds ok. I don't even have the pass door hooked up, casue I infinitely forget until I'm in the car.
 
1 - 3 of 3 Posts
Top