Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
723 Posts
Discussion Starter · #1 ·
Finished it up this weekend...

They sound badass...

Install was pretty straight forward...had an issue with the steering shaft. Had to shim the motor mount up to get the shaft to clear:confused: They are BBK 94/95 LT's...not really a big deal I guess but a PITA none the less. Anyone else have that issue? Dont know if I really like the fact I have washers holding the mount up...but its not giving me any crap YET.

Gotta get to the track/dyno...see what happens:)
 

·
Registered
Joined
·
992 Posts
I'm going to do mine next weekend. I bought prothane motor mounts which supposedly raise the engine about 1/2". I was worried about it, but from what you're saying it may work out for the best.
 

·
Registered
Joined
·
723 Posts
Discussion Starter · #3 ·
JJxUSAF said:
I'm going to do mine next weekend. I bought prothane motor mounts which supposedly raise the engine about 1/2". I was worried about it, but from what you're saying it may work out for the best.
Yeah...1/2 should be plenty. It only took 2 washers to get it up enough to clear.
 

·
Registered
Joined
·
842 Posts
My stearing shaft rubbed too, I drove it around for a day, and it stoped rubbing, no shiming or anything. I guess the heat made the tube a little more pliable, and the shaft pushed it over.

never had problems ever since.
 

·
Registered
Joined
·
317 Posts
My steering shaft rubbed w/ my BBK longtubes. I ran energy suspension polyurethane motor mounts. I had to put a washer or two between the motor and the mounts, problem solved.
 

·
Registered
Joined
·
723 Posts
Discussion Starter · #6 ·
DarkPony said:
My stearing shaft rubbed too, I drove it around for a day, and it stoped rubbing, no shiming or anything. I guess the heat made the tube a little more pliable, and the shaft pushed it over.

never had problems ever since.
I woulda did that...but I couldnt even get the steering shaft on without shimming it.

How does your car sound? Sounds like a badass set-up...:)
 
1 - 8 of 8 Posts
Top