Ford Mustang Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So i have a 87 Gt that i recently built a 306 with a B303-cam, AFR 165s, 24lb inj, gasket matched edelbrock performer rpm2, BBK inner fender CAI, brand new BBk 70mm throttle body, Full MSD ignition, SVE dual electric fans with Aluminum rad, mass air converted but recently it will stumble/fall on its face at idle my wideband will start to read (10.7-11.9) while the rpms drop then ill rev it up and it will clear out and then my AFRs will go back to normal idle (13.8-14.9). doesn't matter if its hot or cold it will intermittionly stumble on its face and run rich, when i drive it at lower rpms it will stumble or run rough but once i get into it around 3500 it'll clear itself out and pull hard thru the rest of the gear. i've changed, cleaned and reclocked the MAF, i've changed the plugs and it helped a little but it will still intermittonly stumble at idle. I dont think my coil is weak bc it was new when i installed it but my next culprit i'm leaning towards is my 02 sensors.
Any help will do thank you! - Colby
 

·
Registered
Joined
·
3,990 Posts
If you are not running a stock mass air meter and injectors, i would try stock and see if that fixes your problem. if it does, your tune needs work via some sore of chip, or similar.
 

·
Banned
Joined
·
25,617 Posts
So i have a 87 Gt that i recently built a 306 with a B303-cam, AFR 165s, 24lb inj, gasket matched edelbrock performer rpm2, BBK inner fender CAI, brand new BBk 70mm throttle body, Full MSD ignition, SVE dual electric fans with Aluminum rad, mass air converted but recently it will stumble/fall on its face at idle my wideband will start to read (10.7-11.9) while the rpms drop then ill rev it up and it will clear out and then my AFRs will go back to normal idle (13.8-14.9). doesn't matter if its hot or cold it will intermittionly stumble on its face and run rich, when i drive it at lower rpms it will stumble or run rough but once i get into it around 3500 it'll clear itself out and pull hard thru the rest of the gear. i've changed, cleaned and reclocked the MAF, i've changed the plugs and it helped a little but it will still intermittonly stumble at idle. I dont think my coil is weak bc it was new when i installed it but my next culprit i'm leaning towards is my 02 sensors.
Any help will do thank you! - Colby
that will never run on stock calibration

people knew this 20 years ago

if you had a totally stock engine, and only put on a 70mm TB, it would run like ass
 
1 - 3 of 3 Posts
Top