Ford Mustang Forums banner

1 - 20 of 105 Posts

·
Banned
Joined
·
1,064 Posts
Discussion Starter · #1 ·
I'm sick of electronic bullcrap, as you can see in previous posts, my car has a check engine light. Ford cant pull codes, and neither can i. I've replaced everything i can think of and cleaned everything else. replaced: MAP sensor, egr position sensor, ect sensor(temp wasnt readin), thermostat(stuck open),
Cleaned: MAF sensor, IAC motor, EGR valve, Throttle body, and checked fuel pressure, things of that nature(plus tune up)
My car is still a bear to start in the morning, gotta keep restarting for like 2 minutes, then when you try to keep it running, it backfires into the intake for like a minutes or so. Then finally it will clear it self out and rev like 600 rpm above what i was holdin it at. If you give it gas while it's backfirin(or runnin like crap) then it doesnt want to rev at all. But once it clears then everyting is o.k. It will also do it every 5 minutes or so while i'm driving....it'll just lose power, and sputter then all of a sudden clear out and run good. Same at stop lights......i need everyones opinion on this please, i need to get this piece fixed or i'm goin carbed, thanks JON
 

·
Registered
Joined
·
5,236 Posts
I personally perfer a carb set up. I liek the easy tunabilty of it. And the fact I can tune it with $10 worth of hand tools. I have been messing with carbs for a long time and have done stuff with EFi as well. I also perfer the price of a carb set up vs the high costs of an EFI set up. By the time your done by MAS and throttle bodies and injectors and everything else just to get yrou car to pull some Hp, you could have spent ~$300 on a good carb. and I dont; spend as much on my intakes either. Some peopel love EFI. I was goign to switch to it to run a Centrifigul CHarger til I found out you can do it on a carb set up, and it is very easy. I used to have a site but I dobnt; have it any more that had a lot to do with your kind of problem. I double checked andf it's nto here. Do a search and see if yu can find som eother posts on it. Search my name and you will find it. I posted the site about a month or two ago. As far as going carbed goes. if yuo decide to go carbed I have a few links that can help you out if you like.
 

·
Registered
Joined
·
493 Posts
stangjon said:
I'm sick of electronic bullcrap, as you can see in previous posts, my car has a check engine light. Ford cant pull codes, and neither can i. I've replaced everything i can think of and cleaned everything else. replaced: MAP sensor, egr position sensor, ect sensor(temp wasnt readin), thermostat(stuck open),
Cleaned: MAF sensor, IAC motor, EGR valve, Throttle body, and checked fuel pressure, things of that nature(plus tune up)
My car is still a bear to start in the morning, gotta keep restarting for like 2 minutes, then when you try to keep it running, it backfires into the intake for like a minutes or so. Then finally it will clear it self out and rev like 600 rpm above what i was holdin it at. If you give it gas while it's backfirin(or runnin like crap) then it doesnt want to rev at all. But once it clears then everyting is o.k. It will also do it every 5 minutes or so while i'm driving....it'll just lose power, and sputter then all of a sudden clear out and run good. Same at stop lights......i need everyones opinion on this please, i need to get this piece fixed or i'm goin carbed, thanks JON
EFI is excellent when its working. I say dont give up on it because you can't find the problem. Keep working at it...the work will pay off.
 

·
Registered
Joined
·
456 Posts
I had some wierd idle problems (it wouldnt) until I cleaned out the salt and pepper shaker connectors and put dielectric grease in there. Also one time, I had a bad connection going to one injector that made it fart and buck when you first cranked it up. I would say check out your connections real good, get some electrical contact cleaner from advance and spray it in there. Good luck. (I was also going to swap to carb if I couldnt get it fixed, I still might some day)
 

·
Registered
Joined
·
1,514 Posts
how many miles? have you replaced the o2 sensors & fuel pump?
i know these things arent cheap but they are parts that wear out on our older foxes. i had an o2 sensors problem that made my car nearly undrivable & codes couldnt be pulled from my car either. as soon as i replaced them my car felt like it was new. no bs. i had way more power & no more drivability problems. i am not saying this will fix it but it will put you in the right direction.
dont give up!
 

·
Registered
Joined
·
9,079 Posts
O2 sensors, fuel filter, check and clean all grounds, Did this all start after you made a change, if so, go back and put stock part back on to see if the problem is still there. Also check for vacuum leaks, it might be something real simple. Start with the basic...spark, fuel, compression. Good luck.
 

·
Banned
Joined
·
1,064 Posts
Discussion Starter · #10 ·
actually, i hink it happened when i was gettin on it one day, and my car torked and ripped the hanger that holds the H pipe on. I had a check engine problem that very instant. I took the car home(boy was it loud and cool soundin) and welded up the hole with a beautiful patch. From then on out its been screwed up. my car has around 65k on it.yes 65 not 165 :)
 

·
Registered
Joined
·
958 Posts
I would check the O2 sensors, because they could of cracked when you broke the hanger. I would also check the intake gasket because of the backfiring. Just to throw some other ideas in the mix
 

·
Registered
Joined
·
337 Posts
I don't think 02 sensors come into play until the car warms up, 5-10 minutes.

I'm not an expert, but I was thinking fuel pressure (regulator, pump) but you've already checked it. Have you checked the distributor? vacuum leak also comes to mind. I see you have aftermarket intakes, did you reconnect all the vacuum lines?

was the car running well recently? was anything done to it that coincides with your problems-mods, servicing?

sorry for your aggravation.
 

·
Banned
Joined
·
1,064 Posts
Discussion Starter · #13 ·
yea, this carhas seriously been a mountain of problems, i'm either goin carbed, or i'm selling it and the supercharger, and buying me a TT car of some sort. No mods, or servicing, just the hanger ripping on the H pipe. And the distributor is brand new. I replaced cap , rotor, wires, plugs, and the distributor itself(shaft bushings were bad, eating rotors everyday)
 

·
Registered
Joined
·
337 Posts
How about the TPS voltage. I have no personal experience with it, but I've seen lots of people mention it.
 

·
Banned
Joined
·
1,064 Posts
Discussion Starter · #15 ·
i have a new tps sensor that I could install. But maybe i should test the old voltage first.....how would i do that though. maybe i should start a new thread.....
 

·
Registered
Joined
·
2,709 Posts
replace your temperature sensor
 

·
Banned
Joined
·
1,064 Posts
Discussion Starter · #17 ·
replaced my engine coolant temperature sensor..... still nothin
 

·
Registered
Joined
·
326 Posts
efi sucks, get rid of all that crap and put a carb on it, i spent thousands on efi stuff only to go back to a carb, i will never again try to mod a efi car, what a pain in the a$$.
 

·
USAF retired
Joined
·
9,363 Posts
When you welded the exhaust pipe hangar what kind of welder did you use? Sometimes welding can screw up the computer unless you either disconnect the battery or pull the computer while welding. Not sure which is correct, so maybe someone else can shed some light on it.
 
1 - 20 of 105 Posts
Top