Ford Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,024 Posts
Discussion Starter · #1 ·
For what ever reason I keep blowing the main fuse for the EEC/fuel pump on my car. It ran fine, sat for a couple of weeks, started for 5 seconds and died.
I then noticed upon trying to start it that the fuel pumps are not coming on for the 3 seconds when the key is turned on. Tonight I found the fuse blown so I replaced it. It's the larger size under the hood. I turned the key on and it blew again. I already checked the wiring to my external pump and it and it's fuse is still good. What gives?

David
 

·
Registered User
Joined
·
733 Posts
i know this probably isnt your problem, but i had a honda, and a main fuse kept blowing becuz i had the battery cables switched with neg on pos and pos on neg, they werent labled so it was an honest mistake....but everytime i try to put that main fuse in id blow...
 

·
Registered User
Joined
·
733 Posts
fuses are wierd.... i know this has not much to do with what your problem is....but like my cruise ctrl and a few other things like dash lights stuff like that, went out and kept blowing id stick in a fuse and istantly blew, i later found out that there was a penny up right in the ciggarette lighter making connection where the cig lighter "should have been" and it was shorting **** out

just a story

hope you get it figured out......
 

·
Registered
Joined
·
2,024 Posts
Discussion Starter · #7 ·
Thanks for the reply. I don't have a cig lighter anymore due to the shifter being there. The fuse that blows controls the fuel pumps and the EEC. I am going to try disconnecting the computer to see if that does anything.

David
 
1 - 7 of 7 Posts
Top