Ford Mustang Forums banner
1 - 10 of 10 Posts

Registered
Joined
1,474 Posts
Discussion Starter · #1 · (Edited)
Would like to give a huge thanks to kjb302ho, always nice to have someone who actually understands cars and speaks the same language, I'd also like to thank Chris over at Pro-M, he's always super helpful, Michael Plummer's posts are how I found out about the system years ago, so glad I stumbled across them and John Janek has also been helpful answering questions thru PM, now with all that nonsense out of the way...

I lost both fuel pumps, likely cause was a shop towel in the 100 micron pre filter, how it got there I have no clue, the fuel system had a few restrictions and I addressed them while the car was down.

I replaced some -6 lines to -8 from the rail output to the regulator, I replaced the return line to a -8 from -6, I replaced both pre and post filters with new Aeromotive filters. I moved the flex fuel sensor to the feed finally, I had it on the return side before against everyone's recommendation, gotta be stubborn sometimes.

I also swapped out my ID1050x injectors prior to this and installed some DeatschWerks 1500cc ones, car had an 7.5ish pound spring in the wastegate and I may be headed back to the dyno to see if I can crack 800hp on low boost 馃槂

I also swapped out my alternator to a TuffWorks 225amp unit, I wasn't confident my existing alternator was up to the task, need to go for a drive with the hood shut to see how this one does.

Top secret message below:

IFE YELLOH < M-ORP

Bicycle wheel rim Bicycle tire Automotive tire Bicycle Wheel
Motor vehicle Automotive design Automotive exterior Auto part Automotive air manifold
Asphalt Road surface Gas Flooring Tar
Tire Wheel Automotive parking light Automotive side marker light Car
 

Registered
Joined
1,474 Posts
Discussion Starter · #2 ·
Car fired right up, idle quality is amazing, I thought I was going to have to make some changes to the fuel map and then realized quickly that I don't actually have to do that, I was also a little concerned about the IAC duty cycle at low speed, I must've gotten some "misinformation" about the Pro-M, none of that stuff is even necessary, it's like magic and all built in already, WOW, guess I can go drive the car now
 

Registered
Joined
3,471 Posts
glad to help. i knew it wasn't ems related but the drop in fuel pressure was a key. im glad the fp sensor did its job and saved your engine. 427w tt. big money.

that ethanol sensor is beautiful isnt it? mounted on the feed and other systems can definitely use it as well since it has a standard gm connector on it.
 

Registered
1965 fastback 347 hci v3-si Pro M efi. Tko600 3:55
Joined
352 Posts
Thanks for sharing, engine bay looks amazing!

Swapping from -6 to -8 lines too and I鈥檒l now check my fuel filters too 馃槅

I hope to get my new build going sometime this winter so it helps to see others finish builds and get driving again.
 

Registered
Joined
1,474 Posts
Discussion Starter · #5 ·
Thanks for sharing, engine bay looks amazing!

Swapping from -6 to -8 lines too and I鈥檒l now check my fuel filters too 馃槅

I hope to get my new build going sometime this winter so it helps to see others finish builds and get driving again.
Still a mystery how that thing got in there, after losing two fuel pumps I'm hoping that was the cause. If it wasn't, maybe the -6 return was hurting once I switched to E85, either way the issue should be resolved now I hope. Haven't built confidence yet to go drive it much, I'm still pissed about it, hope that changes, but for now it's running, I've got two things to fix now though, the passenger side turbo drain is leaking at the 90 swivel at the pan and I'd like to re-route my driver side cold side slightly to change to a different fan setup, always gotta have something to do to stay interested.
 

Registered
Joined
3,471 Posts
If you really want something interesting, and you really want to do something that will take days if not months to complete, have you pulling your hair out and lighting the car on fire:

Install a terminator x..

nothing like making more work for yourself.
 

Registered
1965 fastback 347 hci v3-si Pro M efi. Tko600 3:55
Joined
352 Posts
Still a mystery how that thing got in there, after losing two fuel pumps I'm hoping that was the cause. If it wasn't, maybe the -6 return was hurting once I switched to E85, either way the issue should be resolved now I hope. Haven't built confidence yet to go drive it much, I'm still pissed about it, hope that changes, but for now it's running, I've got two things to fix now though, the passenger side turbo drain is leaking at the 90 swivel at the pan and I'd like to re-route my driver side cold side slightly to change to a different fan setup, always gotta have something to do to stay interested.
Well. ..
鈥our list is way shorter than mine馃槵
Keep us posted on the progress.
I鈥檓 looking forward to playing with all the cool stuff this system offers again.

My biggest goal is to make drag radials work (consistently) with manual trans.
Just got a flow control valve to help the clutch slip a bit at launch.
That along with the launch control, two step and traction control will help
keep up with the Tesla boys now 馃槑
 

Registered
Joined
1,474 Posts
Discussion Starter · #9 ·
Well. ..
鈥our list is way shorter than mine馃槵
Keep us posted on the progress.
I鈥檓 looking forward to playing with all the cool stuff this system offers again.

My biggest goal is to make drag radials work (consistently) with manual trans.
Just got a flow control valve to help the clutch slip a bit at launch.
That along with the launch control, two step and traction control will help
keep up with the Tesla boys now 馃槑
I haven't got to test out the traction control as much as I would've like to, at 5psi the car was somewhat predictable going WOT, the car made 600/600 at 5psi, I changed to an 8psi spring to try and possibly get to 1,000hp, but the 2 times I went WOT it got scary pretty quick, I really wish I could rent out a runway or something to do some real testing 馃槀 , I keep forgetting about launch control to, I only tested it out once on the street and my single trip to the drag strip I had issues likely related to the fuel system issues I had now looking back on it.
 

Premium Member
Joined
5,988 Posts
I appreciate the kind words but you have put together a pretty stout combination for yourself and I hope your combo makes all the HP you're looking for.

Good luck
Michael Plummer
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top