Ford Mustang Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1,558 Posts
Discussion Starter · #1 · (Edited)
Hey guys,

I got rid of the restrictive cobra inlet tube that didn't fit my GT and Bullit intake correctly b/c of the valve stem on the passenger side and me and a friend made a custom 4" Cold-air induction kit using a 45" degree elbow and a densecharger tube from www.densecharger.com but had to modify it because it did not fit over the valve stem correctly either :mad:

My question is, ever since we made the setup and reset the battery the car is making a funny sound after you rev the engine it is like a 1 second delay from when you rev the engine and let off the throttle it will make this "drone" type sound or a similar sound like an air horn. I am thinking the 4" tubing running from the MAF/Filter combo up to the T/B is too big and trying to push more air into the T/B then it can handle, thus causing the noise. My valve stems are also rattling or tapping now as well or something is, we believe the rattling is somewhere in that area. Could the car be pinging since I had the car tuned for a 3" setup and swapped to the 4" so its running rich/lean maybe? When I drove the car today you can hear the noise really good at low speeds (almost idle) and you can even hear it at idle but not as loud.

What do you guys think, should I change my setup back to the 3" but chunk the inlet tube and use a piece of PVC pipe or could it be something else? I had 0 problems until I swapped the intake setup out last night. The car does not feel down on power nor is it surging so I am kind of stumped.

Thanks.
 

·
Registered
Joined
·
3,173 Posts
Maybe you don't have it sealed to the throttle body good enough, and when you back off the throttle, air is coming out?? :confused: Its honestly hard to say. Why don't you link me to a pic of your setup??? Thanks!! :D
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top