Ford Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
I installed a Baumann shift kit today. I set the shift firmess on level 4 (out of 5), bumped the line pressure up, and installed all the 2-3, 3-4, etc shift improve stuff. The transmission shifts nearly identical as the way it did prior to the shift kit. I did manually shift 1-2 a couple of times and it shifts very firm. Although when it's in drive at WOT it shifts a little faster and that's it.

My mods if it matters;

TFS Track Heat intake
1.72 rockers
Stock ported heads
Pullies
Dynomax cat-back
2:73 gears (yea baby!)

Any ideas?

Thanks
Matt
 

·
Registered
Joined
·
916 Posts
You know, I had the same problem at first, but I had the 1-2 shift set at 4 and the rest at 3. I left mine in D and punched it when it was in first, right when I wanted it to shift I would pull it down into 2nd. This would make me go sideways. I was fun. I couldn't get 3rd to chirp. I think after time my tranny shifted harder, because now it shifts hard no matter what. Hope this helps. Good Luck.

-Billy
 

·
Registered
Joined
·
131 Posts
It may also have alot to do with the shape of your tranny and clutchs.

If the clutchs are all worn out, or if you have seals that lets fluid get past them, you may not get adaquet pressure to the clutch packs.
 

·
Registered
Joined
·
104 Posts
Discussion Starter #4
The transmission has about 1500 miles on it. It was rebuilt by a ford tech using all Baumann hard parts. We replaced the factory style direct clutches with the Raybestos racing blue, and changed the intermediate setup over to 4 clutches instead of 3. Other than that we placed all the piston seals, cluthes, OD band, etc. The entire transmission was freshened up. One thing that has been messed up from day one is when you press the throttle to about 1/2 while in O/D the motor will rev up to say 5000rpms then bang into the proper gear. It did this prior to the shiftkit and still does it. The guy that rebuilt the transmission said the 2/3 shift valve in the valve body might be hanging up. Other than that, the transmission worked fine before the shift kit.

I'll call Baumann tomorrow and see what they recommend.

Matt
 
1 - 4 of 4 Posts
Top