Ford Mustang Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7,462 Posts
Discussion Starter #1
Anyone have any hot start issues with 42 lbers and a Pro M 75? This is for a 302 with HCI.
I have heard of issues but some say it is the Pro M 75 and not the 42's.
Anyone running the Pro M 75 and 42 without issues or is there a different meter that is better?
 

·
Registered
Joined
·
1,918 Posts
I don't have 42 lb injectors or a PROM 75, but I did have hotstart issues. I have 24 lb injectors with a C&L 76mm. The only thing that has pretty much resolved the hotstart issues was a TwEECer and some tuning.

You have big injectors for a HCI engine. I'm guessing supercharging is probably in your future?? If so look hard at getting a tuner as you are going to be laying money out for it or a chip if/when you get blown.
 

·
Registered
Joined
·
7,462 Posts
Discussion Starter #4
Yea. A SC is in the future. Looks like the only cure is to go with smaller injectors (30' or 36's) or get a tuner?
 

·
Registered
Joined
·
7,462 Posts
Discussion Starter #6
What is the cost of a chip? Could I mail order one? If I have to go for a dyno tune and have a chip burned, I think I would be better of buying a tuner of some sort.
 

·
Registered
Joined
·
1,918 Posts
wldtang said:
What is the cost of a chip? Could I mail order one? If I have to go for a dyno tune and have a chip burned, I think I would be better of buying a tuner of some sort.

Even with a tuner you are still going to have to pay for dyno time, unless of course you have a wideband. However, with a tuner it is not going to cost you money to make changes where the reburn of your chip will.
 

·
Registered
Joined
·
7,462 Posts
Discussion Starter #8
What does it cost to have a chip burned?
 

·
Registered
Joined
·
1,918 Posts

·
Registered
Joined
·
7,462 Posts
Discussion Starter #10
any idea how accurate these will be?
 

·
Registered
Joined
·
1,918 Posts
I don't know much about chips. I know that I have far from done in regards to changing my combo so I opted for the TwEECer.
 

·
Retired U.S. Air Force
Joined
·
1,695 Posts
I had the hot start problems with my 42's and 75 Bullit. I run a Procharger so I went with the blow through Bullit. No chip and I was able to get it to start fine. I had to play with the throttle position and TPS as well as fuel pressure but I got it to work fine. It seemed to like more fuel pressure and to set open the TB blade slightly. Your idle may go up as mine went up about 50-60 rpm's more when it was all said and done. You can get it to work but it takes time and tuning. I could run all day long, shut it off and turn it back on in 5 minutes with no problems. It was rich when I stomped on it from a light though.
I planned to get a chip but ran into other problems.
I'm still using the same setup and will get a chip but till then, I'll do the same as before.
Dave
 
1 - 12 of 12 Posts
Top