Ford Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
I just got my 95 gt convertable back from the shop, i had all the motor gaskets changed. I know they had to remove the drive shaft and tranny from the car, and take apart themotor of course, and when i picked up the car and drove it home, i realized there the ride was very bumpy.

at 2k rpms, its smooth, decent ride, but when i punch down on the throttle, it feels like im going over a bunch of bumps. as if something is not balanced correctly. when the car is in neutral though, such as at a stop light, when i rev up the engine, its clean, feels good, car isn't bumpy at all.

could this be my drive shaft was improperly installed? something up with how they put my tranny back in? ignition problems? tires unbalanced/need alignment? if you have any infor id greatly appreciate it
thanks corral
Travis
 

·
Registered
Joined
·
556 Posts
take it back to the shop
 

·
Registered
Joined
·
2,105 Posts
Sounds the like installed your driveshaft improperly....take it back to the shop.

Who did you go to? I noticed you were in Northern Virginia...was it Springfield Motorsport, Jax Auto, or Execssive Motorsport East?

Somebody else?
 

·
Registered
Joined
·
119 Posts
Discussion Starter #4
I went to a local shop in Leesburg, they have done a good amount of work for me, and I've never had complaints. But this time when i told them what was wrong "it was my fault" as they put it. so I took it back this morning *****ed them out, and its being worked on right now.
thanks fellas
T
 
1 - 4 of 4 Posts
Top