Ford Mustang Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
Can someone tell me the proper way to set up gt40p heads to work with a roller cam with a lift near .590. I know about the crane kit. Im wanting to do this w/o using the machine shop. Thanks in Advance
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #3 ·
if you don't port it don't bother with that much lift, they don't flow more much past .500 on the intake side. I have an www.alexsparts.com kit in mine, not the beehive kit though, it wasn't available when I did mine. I run a comp cams XE270HR
Cool. Thanks...were yours simply gasket-masked or did you go a steps further?
 

·
Registered
Joined
·
317 Posts
I also used XE270HR-14 cam and a "drop-in" spring kit from AlexsParts with 40P heads. I also shaved the heads .030, machined to accept stud mount roller rockers and ported the exhaust side. It only ran 13.80 @ 100mph with AODE/3.27 geared rear but when I took it to the dyno we found some transmission slippage every time we hit full throttle.

The cam and spring kit did not require any machine work to use. I did the work looking to get more out of it.
 

·
Registered
Joined
·
186 Posts
I have an explorer upper/lower that I gasket matched a 70mm throttle body and the upper to lower. Didn't touch the lower to head even though it could have used a lot of work on both sides; 270rwhp/310tq.

I figured if I was going to go through all that I may as well get TWS heads first
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top