Ford Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
577 Posts
Discussion Starter #1
How much of a chance is it for your rack and pinion to go bad? When it does will you know or can you still drive with something wrong. Reason I'm asking it that I have some searious noise coming from the steering when turing the wheel back and forth, I have had several suggestions as to what it might be, bushings, tie rods ends, low power steering fluid(it's just a hair above min by the way).......

It's gotten to the point where it sounds like a grinding noise when turning and it's getting on my nerves as well as worring me!

Also is this worth the money and how hard to install if mine is going bad?

http://www.brothersperformance.com/shop/mustang/fr1892.html
 

·
Registered
Joined
·
1,724 Posts
You could try getting a can of spray grease and cutting the tube with a razor blade into a point. Then push the point into the boots of your ball joints and fill them with grease. This stopped my creaking when I turned the wheel.

Dwayne
 

·
Registered
Joined
·
577 Posts
Discussion Starter #3
Anyone else?
 

·
Registered
Joined
·
577 Posts
Discussion Starter #4
Ok tried what you said, I poked a small hole in the boot here and sprayed WD-40 in there in hopes of it helping..... Still creaks but I will drive it today and see if it goes away after time, anymore suggestions?

It is much louder on the drivers side, I don't hear it on the passenger side.....

 

·
Registered
Joined
·
1,724 Posts
I would really use a grease WD40 is way to thin to offer any wear protection. Remember you have the track rod ends and the lower ball joints to do not just the rod ends. It could be the upper strut mounts on the camber caster plates also I suppose?? worth a look anyway.

Dwayne
 

·
Registered
Joined
·
22 Posts
Check out the top strut plate/bushing assembly. My G/F had a similar problem years ago on her escort. It turned out to be the top strut bearing assembly.

Good luck
Terry
2000 GT Convertible
2000 Z28
91 GT - sold it and sorry I did :(
 

·
Registered
Joined
·
2,354 Posts
replace your inner and outer tie rods and you should be fine.i had the same problem a few months ago.
 
1 - 7 of 7 Posts
Top