Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
post not working for me, trying again......Every time I get int the boost hard for a long pull, (3rd & 4th high rpm) I get a funny smell. To me it smells like the cats and exhaust getting hot. It goes away after I slow down/ cool down. Anybody else have this problem?
 

·
Registered
Joined
·
15 Posts
How long have you had the car and how long have you had the smell?
There's always a strang smell whenever your breaking in a new car. It comes from the exhuast as the oils in the exhaust heats up and burn away.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Its got about 5100 miles on it plus the Bassani system.
 

·
Registered
Joined
·
171 Posts
Thats normal man... Mine does it... The stock programming from ford tends to run fatter at higher RPMs 4k and above on these cars.. My 01 cobra did, so does my 03... Get that kinda funky smell, hot cats/fuel... I wouldn't sweat it too much... If your really worried you might wanna dyno with wideband 02 and see what your A/F looks like under WOT...

Great source of 03 cobra info here

www.svtperformance.com goto the 03COBRA forum
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Great source for info! Thanks for your input! Nice to know my car isn't going to grenade any time soon.
Thanks
 

·
Registered
Joined
·
171 Posts
VegasMcStang said:
Great source for info! Thanks for your input! Nice to know my car isn't going to grenade any time soon.
Thanks
No problem man.. Great FAQ over their, and decent bunch of guys... I am 03Sssnake over there. You might not wanna take all of their gripes wholeheartedly, they tend to exaggerate their cobras "issues"
 
1 - 6 of 6 Posts
Top