Ford Mustang Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi guys, I just got done with my head swap on my 93 coupe. I put tfs heads/intake and tfs stage 1 cam in it. I got it started and let it idle for a while then drove it around, everything was fine. Then I parked it and now it wont start. I left my alt. unplugged so I thought that I might have killed the battery, but I got it recharged. All it will do is click, and maybe crank once weakly. What could be wrong. I have no clue, help me out guys, thanks Chase
 

·
Registered
Joined
·
713 Posts
well clicking is a dead battery, whatever reason its dead
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
I thought it was the battery but like I said, I went and had it recharged. Someone told me that the distributer might have game loose after playing with the timing, but that does not seem to be the case. I really want to get my car going, any other suggestions, this car is my daily driver. Thanks Chase
 

·
Registered
Joined
·
1,342 Posts
Pull all the plugs and try to turn it over. It's possible a cylinder filled up with water :(
 

·
Registered
Joined
·
1,817 Posts
Chuck98GT said:
Pull all the plugs and try to turn it over. It's possible a cylinder filled up with water :(
I dont see how?

87gt dude!! You spent 2k on all the stuff you just did, Do not let a little 50.00 battery ruin it for you. ITS YOUR BATTERY!! GO GET A NEW ONE!!!
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
Its not my battery, I just pulled the plugs, and now it cranks, so does that mean I have water in my cylinder. help anyone
 

·
Registered
Joined
·
6,049 Posts
87gt5.1 said:
Its not my battery, I just pulled the plugs, and now it cranks, so does that mean I have water in my cylinder. help anyone
The battery could be weak and having trouble against the compression, or you could have a poor electrical connection somewhere.
If you have water in a cylinder, there should be some evidence of that, but you may have to turn it over by hand to check each cylinder.
 

·
Registered
Joined
·
713 Posts
really no plugs in and it turns over yet another miracle.
 

·
Registered
Joined
·
1,817 Posts
lol, Once again get another battery, or atleast try another battery from another car.. It will work then...
 
1 - 12 of 12 Posts
Top