Ford Mustang Forums banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Bad Heads you sold for my 4.6

Josh,
I've sent you several emails about the bad 4.6 2V heads you sold me. Your buddy who did the porting supoposedly going to work for Fox Lake ported them -LOL. Well he doesn't know **** about porting. He didn't even do the short turn radius at all but oh yeah he did port them into the water jackets so now I have a junk set of heads. I spent over $1,300 on the heads with all new parts including what I paid you and you're not even man enough to respond to my emails. You told me they were off a motor with low miles, they had to have all new guides even - what's that all about. They were junk from the begininng.

I hope you get better treatment than you give as you pursue your FE swap in your stang. I'll bet this thread gets deleted right away!

Stay away from this guy.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
clean out your email and you would hear from me! when i sent you the heads i told you to takee them to your guys and get them checked out (before you buy them) and you then called back and said you wanted them, your did you forget that!!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
jim,
after you bought them you called me back (mad), and said your guy told you the valves were to short, then called back and said sorry he was wrong. did you ever think your guy may be screwing you??? wouldn't that be funny!! i have sold alot of parts on the internet and never had any problems except from you!! write up a post and ask how many people had bad experance with me and you will see.
i would never try a screw anyone, never!!
 

·
Registered
Joined
·
6 Posts
What

Josh. I emailed you twice to ask if there was anything we could work out and YOU never responded. You know what that says...you don't want to own up to your repsoinsibility. Yeah we got the valves issue straightened out. Then when we started up the engien it puked out water like the niagara falls. I took off the crossover pipe for the turbo and one side was dry and the other was totally wet. We then pressuirized the system and water was flowing out of the number 2 cylinder exhaust side. I have had my machine shop and a professioanl head porter both look at the head. They both say it was ported into the water and way too much on the ports. BTW , those lwo mileage heads had to have every valve guide replaced as well.

No, Josh, I don't think you're a bad guy - quite the opposite. but dodging the issue makes you seem guilty. Like I said in my emails to you we should be geting the guy who portd them for you. NOW, that we're talking (over a public forum instead of the way I preferred and tried before) what do you propose?

I've been listeneing all along...
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top