Ford Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
349 Posts
Discussion Starter #1 (Edited)
My engine is acting really weird. If I run it hard from a roll, once I get to about 3500 it will just flat out stop, and the tach falls immediately to like 2500, then jumps back up to 3500ish , and just keeps hesitating and will slowly work it's way up the RPM range. Some times it doesn't start till like 4500rpm, sometimes it will make a clean pull to 5500. But the thing that scares me is how violently it cuts out sometimes. It will ripping past 35-4500 rpm, then HITS A WALL... it stops so bad that i almost go out the windshield. The whole thing just stops. Then I shift cuz I think i hurt it. But sometimes it works fine. Others it just hesitates it's way up the tach past 35-4500. It's running perfect from idle to 3500. Never acts up. But after 3500 it might work, might hesitate, and might just stop so bad you have to shift. Also if i put it in neutral and rev it slowly, it goes up smoothly till 3500 ish, the the tach kinda "wavers" around and slowly goes up, sometimes it wont rev past 3500, it just stops. I have put 1.7rr's on the exhuast, new cap & rotor, new plugs and wires and cleaned the Mass Air, Throttle body, set timing to 12* and I can not figure it out, I have tried moving the tming up and down, nothing works. Please Help. Adam
 

·
Registered
Joined
·
349 Posts
Discussion Starter #2
ttt
 

·
Registered
Joined
·
410 Posts
I'm having about the same problem, but mine starts acting up around 5000rpm's. Have you checked the fuel pressure?
 

·
Registered
Joined
·
349 Posts
Discussion Starter #4
No but my friend has an adjustable regulator with a fuel pressure gauge mounted on the schrader valve, i'll see if I can borrow the guage to check it. Today it wasn't doing it until 4300-4500, but I could not get it to rev above that, in gear or in neutral. Adam
 

·
Registered
Joined
·
1,202 Posts
Pull codes and see what you get. It could be the fuel system but I would suspect a clogged EGR Valve.

CobraGreen said:
It will ripping past 35-4500 rpm, then HITS A WALL... it stops so bad that i almost go out the windshield.
WEAR YOUR SEATBELT!!!!!!!!

James
 

·
Registered
Joined
·
349 Posts
Discussion Starter #6
Seat belt...

I am wearing it....but I am starting to fear for it's durability!!!! :( I need to fix this....if not for anything else but to prolong the life of my seat belt ;)
 

·
Registered
Joined
·
349 Posts
Discussion Starter #7
Isn't there a way to pull the codes by turning the key???
 

·
Registered
Joined
·
349 Posts
Discussion Starter #8
Ok i pulled the codes. I'm getting a KOEO code of 87: Fuel Pump Primary Circuit Failure?????? What will this do...and how do i fix it? Would this cause this? Wouldn't my car not run at all? Or when it cuts out, does it trip this code, and it saves it?
Also I get a KOER code of 44: Thermactor not working on the right side, (broken vac lines).
And a Continous Code of 29: Insufficent input from the Vehicle speed sensor, but my cruise control works fine??? Any one? How do I fix the fuel pump code? Adam
 

·
Registered
Joined
·
1,202 Posts
Code 44 is part of the EGR system. I honestly don't know a whole lot about how the computer and sensors interact with one another. Start a new thread paging Stangplus2birds. I believe he is more educated/experienced on this paticular subject. If you had a fuel pressure guage mounted on the outside of the cowl, you could see if you are losing pressure when it acts up. But, like I said before, I don't know if other sensors could have an effect on the fuel circuit..................James
 

·
Registered
Joined
·
349 Posts
Discussion Starter #10
Thanks for all the help, maybe some one will stop in. In the mean time I'll change the fuel pump relay. Adam
 

·
Registered
Joined
·
349 Posts
Discussion Starter #11
TTT
 
1 - 11 of 11 Posts
Top