Ford Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,097 Posts
Discussion Starter #1
alright i was driving down the road the other day and all of a sudden i hear a loud pop then every damn warning light that could come on beneath my gauges lit up then the car dies and will not start up...got it towed to the dealership...the day after the *******s call me and aske me who put on and i quote "all this hot rod stuff" i knew i was in deep **** right there...but anyway they say it seems like this "fancy" ignition youve got here is causing the problem...so i say no problem and get it towed to the shop that installed the ignition...well they test the ignition and its just fine they run tests on the car for about a week...then finally yesterday they find out that the eec-v is toasted...my question is how the hell did this happen...is this a problem with our computers that they just toast themselves for no reason...odd thing is about a month ago the computer in my dad lincoln ls died for no apparent reason...and im also kind of pissed off at the dealership...the aftermarket ignition had nothing to do with the computer shouldnt they have been able to tell it was the computer???...any ideas on this guys?
 

·
Registered
Joined
·
103 Posts
the techs at the dealerships are lazy. unless they are hot rod enthusiasts they don't want to [email protected] with any modified cars. I have a plug in adapter that allows me to use the older slyle computers in my 94 and when I went to ford to have a lean issue diagnosed I recieved the same treatment as you. stupid a$$holes. I have, as of yet, not solved my problem but one thing is certain, my lack of confidence in the manufacturer of my favorite car.
 

·
Registered
Joined
·
7,628 Posts
cingularchris said:
the techs at the dealerships are lazy. unless they are hot rod enthusiasts they don't want to [email protected] with any modified cars. I have a plug in adapter that allows me to use the older slyle computers in my 94 and when I went to ford to have a lean issue diagnosed I recieved the same treatment as you. stupid a$$holes. I have, as of yet, not solved my problem but one thing is certain, my lack of confidence in the manufacturer of my favorite car.
Please DO NOT bypass the word filters in the future.

Thank you,
Tim
 

·
Registered
Joined
·
137 Posts
most dealership tech don't know there but from a hole in the ground. I went back to ford 4 times for a vibration problem I found it my self the rear spindle nut backed off and the back wheel almost come off.
 

·
Registered
Joined
·
170 Posts
how does your MSD ignition get tach signals? must be connected to the computer at some point in the system? check your connections for the MSD to find the problem before you install another computer. also check out the fried computer. is it just a burnt trace or blown fuse. maybe it can be fixed.

I have no love for ford service departments, but I do have two good stories:

1. took my girl friends gt in for a whining rear end and to get some new pats keys made. they fixed it under extened warranty. $1200 parts and labor. cost us $160. they forgot to charge us for the keys and the pats computer reprograming (only had one key). would of been $150 for the keys and reprogram alone. there is a first time for everything!

2. last week I went to ford to get gear oil and friction modifier for my 4.10 gear install in my 02 gt. $18 a quart (need 2) for the gear oil and $43 (4oz bottle) for the friction modifier. talk about highway robbery. Could not find anyone else who sells the damn synthetic gear oil in the 75w - 140w that it calls for. Now you know why I didn't go back and tell them about the keys.
 
1 - 5 of 5 Posts
Top