Ford Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
643 Posts
Discussion Starter #1
Does it become bad again in a couple of days?
 

·
Registered
Joined
·
291 Posts
yeah, on my 99gt, i cleaned it, and it did nothing. replaced the IAC, and it didnt help anything, either.

on my 95gt, i just cleaned it, and now the idle is worse.:rolleyes:
 

·
Registered
Joined
·
257 Posts
I took mine off the car, filled it up with carb cleaner, covered the tubes with my fingers and shook it for a minute and poured out the nasty stuff. I repeated this until the fluid came out clean and made sure that the little plunger moved freely. I also used a screwdriver and a rag to wipe what parts of the plunger and surrounding areas I could reach. No problems since. This was almost a year ago.
 

·
Registered
Joined
·
1,558 Posts
I drenched mine in carb cleaned, used WD-40 on it as well, and got a small razor blade to get the junk off of the turning piece. It fixed my problem majorly. My car would stall everytime you pushed in the clutch, hasn't done it since. (knock on wood!)
 

·
Registered
Joined
·
31 Posts
I used carb cleaner and a method similar to Mo-D's about 6 months ago and have had (0) IAC problems since. Give it a try, can't hurt and may save you a few bucks.
 

·
Registered
Joined
·
451 Posts
There's plenty of threads on this, but I did the same.. carb cleaner until it cleared up completely.. haven't had a problem since
 

·
Registered
Joined
·
643 Posts
Discussion Starter #7 (Edited)
Will electrical contact cleaner work?
Do I need new gasket?
Torque spec on bolts?
Thanks.
 

·
Registered
Joined
·
192 Posts
Where is the IAC located? Does anyone have any pics of where it is? I can't find any pics, and I'm not familiar enough with our cars to be able to point it out.
 

·
Registered
Joined
·
643 Posts
Discussion Starter #10
If anybody wonders accordingly to Helm manual torque spec is 75-106 lb-in, which is hand tight.
 

·
Registered
Joined
·
152 Posts
Yep, took mine out, sprayed it with Carb cleaner. 15,000 miles later, still no problem.
 

·
Registered
Joined
·
106 Posts
i just walked in from cleaning my IAC and i'm hoping it solved my problem. my idle is really bad. i sprayed it down really good with electrical parts cleaner. when i started it up it still seemed a little rough, although i havent taken it out yet or kept it running for very long. i'll try later and see how it goes.
 

·
Registered
Joined
·
5,957 Posts
After you clean it, make sure you move that piston back and forth. I still have my original IAC after 206K but I've cleaned it 3 times now.
Erich
 

·
Registered
Joined
·
3,263 Posts
ERICH....

...Your Killin' Me :D

c'mon, iam trying to make a buck here!!

200k on the oem IAC?:eek: ?
(i'll give you my spare)lol
Randy Stinchcomb

p.s. Erich, your car is amazing:)
say"hi" to Sue
 
1 - 14 of 14 Posts
Top