Ford Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
I've been getting a weird rasp, from my car latley when i hit around 4,000 and on. I never heard it before but i was thinking that maybe it's detonation, I ported my heads and intake, my rockers are set up correct and i don't think it a header leak because i just resealed them. I'm runing 17 degrees of timing, same as i always have. I haven't tried to change the timing yet, but i'm going to as soon as i'm done here. So if everything flows better than before porting, it would seem that i would be getting more air in the cylinders now, and that the engine would be compressing more air, so there would be more pressure ? I don't know, does that sound right ? Anyone yell out any suggestions, i also installed a MSD billet dist. With my porting.

Thanks.
 

·
Registered
Joined
·
1,069 Posts
you didn't touch the combustion chambers right? any real sharp edge in any cc will cause detonation
 

·
Registered
Joined
·
155 Posts
Discussion Starter #3
no edges

Everything was fine, until i got on it a couple times one night, I changed the timing back to 13 degrees but the noise is still there, All the spark plugs looked fine when i checked everything out yesterday. Maybe i just got some bad gas ? I'm going to increase the fuel pressure and move my MAF around, becuse i've heard it makes a difference in what position it's in. other than that i don't know, i got the limiter set to 6000, so i wouldn't have thought i blew anything up, an ideas ?

Thanks.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #4
ttt

ttt
 

·
Registered
Joined
·
873 Posts
Sounds wierd to me. Try a pound more of fuel pressure. It's very wierd that you took the timing back and it's still making the noise. Is it still there but not as loud?
 
1 - 5 of 5 Posts
Top