Ford Mustang Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
548 Posts
Discussion Starter · #1 ·
I installed my MM coilover kit with Tokico shocks yesterday. When I am driving normal, I can hear a little clanking noise sometimes. Other times when I hit bumps, they are fine. I am going to double check it to make sure, but I swear I tightened everything.
Anyone had the same problem with a coil over setup? Thank
 

·
Registered
Joined
·
411 Posts
Did you upgrade caster/camber plates as well. All the weight of the front end is now at that point of the strut tower.

Check to make sure you have clearance between coil spring and the frame bracket that holds the flexible brake hose. This is usually a problem.

Also do not use any metal spacers on the strut shaft BELOW the coilover assembly. Start using these above the little torrington bearing hat.
These are just some things to check and help ya that I have run into.

Good luck

JT
 

·
Registered
Joined
·
202 Posts
As JT stated, the brake hard line and bracket may have to be relocated or slightly bent in (this requires exreme caution not to kink line). that is what caused this very same problem when I first installed my coilover kit. Does the MM CC plates have a spherical bearing or urethane bushing? This was another problem I had, the bushing would bind and the tower actually "flexed" while turning the wheels! Good luck.

Andy
 

·
Registered
Joined
·
4 Posts
make sure the springs are seating properly
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top