Ford Mustang Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
ok so i start my car last month, and the engine light came on, no big deal right its probably nothing.. any ways so i take it down to my friend and he gets the code read for me and it says that 02 bank 2 is running lean, im htinking this probably just happened because of my C&L maf.. so im like whatever, ill worry about this a couple months from now, no big deal with it... so anyways i filled my car up with gas and always reset the o/d.. ever since that day ive notice a huge loss in mpg, when i was getting nearly 280-300 now im getting at BEST 210... here is a list of my mods someone please help i have no idea whats wrong.. K&N, C&L MAF, C&L Trueflow pipe, BBK 70mm TB, C&L upper intake, Steeda Intake Spacer, Mac Off road H-Pipe, Mac Catback exhaust, and Steeda MIL Eliminators(think they are broke tho)... feel like my mpg gets worse everyday and thats not driving the car hard at all shifting at 3k.. makes me think the car is running rich, i have no idea though
 

·
Registered
Joined
·
125 Posts
You don't mention the year of your car. I think you need to clean the electronics on your MAF. My car was running like CRAP a while ago, misfire codes, CEL, etc, and I bought new O2's thinking it was that. Well I read around on this board and found that people were having good luck with using non-chlorinated break cleaner and spraying the elements on the MAF electronics. I unplugged my battery, removed the electronics (didn't have to pull the housing) and gave it a quick shot with the brake cleaner. I haven't had a check engine light in more then a week and my car runs perfect. Try that before you spend money on anything.

If that doesn't work, you might try replacing your front O2's. Look for the thread that Pintoman started (New O2's for sale) I bought those and he got them out to me right away and at a great price.
 
1 - 2 of 2 Posts
Top