Ford Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1
I just got mine back from BBK and it looks great, but the blinker arrow in the upper left hand corner is bright green and doesn't at all match the factory arrow on the upper right corner of the tachometer. I don't know how to better explain it, but the factory blinker arrows show up green when in use ONLY! The one on the BBK unit is bright green just sitting here on the table. I guess my question is: Has anyone else come up with a solution for this and if so, what is it? I thought I could peel off the green, but it doesn't look like that is possible without screwing up the speedometer. I don't want to have to call them and send it back, but I guess I will if I have to. Let me know what you guys think. Thanks alot!

Barry DeLassus
www.netexpress.net/~bdlass
 

·
Registered
Joined
·
183 Posts
maybe there is more shadow on the other signal making it darker, did you take the tach out of the whole housing and place them side by side? you could always go ghetto and put a piece of scotch tape over the brighter one, that would not let as much light through
 

·
Registered
Joined
·
88 Posts
Discussion Starter #3
It's hard to explain, but it is almost like the green part is a sticker or a coating on the back of the speedometer. It doesn't look like it will come off very easily. That may or may not make any sense at all, but those who have had this conversion done will probably know what I mean. Any other ideas?

Barry DeLassus
www.netexpress.net/~bdlass
 
1 - 3 of 3 Posts
Top