Ford Mustang Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
I was playing on the street with my coupe last night and I romped it from a second gear roll. The car deadhooked and took off, but at the same exact tme the battery light came on. I can't figure out what is wrong :confused:

The battery is held down tight in the factory location
The alternator is charging perfectly
The car starts fine

Any ideas?
 

·
Registered
Joined
·
182 Posts
Discussion Starter #2
ttt
 

·
Registered
Joined
·
154 Posts
My car had the battery light on also. The car was charging fine and running good. It ended up being some type of internal problem with the alternator. I just put a new one on because I was afraid that someday I would get stranded somewhere.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #5
fiveoh said:
Is the light still on?
Still on :(

LX-8UUP - How did you figure out it was the alternator? Did you have it tested, or did you just replace it and it went away?

I wonder if it is possible to damage the battery internally and that would trigger the light?
 

·
Registered
Joined
·
545 Posts
Check to make sure the lower plug for the alternator is still in.

Nik
 

·
Registered
Joined
·
182 Posts
Discussion Starter #7
Niks90coupe said:
Check to make sure the lower plug for the alternator is still in.

Nik
I will do that, it is possible it popped out when I jumped on it.

Will it still charge with the plug out though? I drove about 40 miles with the Mark VIII fan and headlights going with no problems after the light came on...
 

·
Registered
Joined
·
545 Posts
I made a pass at the strip, started it multiple times and drove it home, charging fine with the battery light on. It blows up, common problem with ford alternator harnesses. If this is what happened you'll need a new harness and alternator.

Nik
 

·
Registered
Joined
·
182 Posts
Discussion Starter #9
Niks90coupe said:
I made a pass at the strip, started it multiple times and drove it home, charging fine with the battery light on. It blows up, common problem with ford alternator harnesses. If this is what happened you'll need a new harness and alternator.

Nik
It blows up? :confused: :eek: What blows up? Are we talking fire hazard? Do I need to just replace the connector or the compete harness. I have the 130A alternator FWIW.
 

·
Registered
Joined
·
545 Posts
I don't know about a fire hazard, or if its a problem with the 130s but it just explodes and comes out. I don't know if it is a fire hazard. Since you have a 3g, I don't think this is your problem. But I'll still bet its your alternater.

Nik
 

·
Formerly AHD
Joined
·
351 Posts
Matt:

Could be the rectifier inside the alternator. I had this problem years ago in my 79 cutlass supreme. Gen. light came on. Turned out to be the rectifier(diode trio). One of them was bad, flowed juice in both directions. You might be able to buy one for the 3g and install it yourself, buy i'm not sure since I haven't worked on one internally yet!
 

·
Registered
Joined
·
182 Posts
Discussion Starter #12
Thanks guys. I know I got a little bit of oil on the alternator when the Vortech return line had a small leak. I fixed it a while ago, but maybe it has finally screwed it up? I'll yank the alternator and take a closer look at it. Hopefully it's something simple...
 

·
Registered
Joined
·
154 Posts
I had my alternator tested and one of the lights on the harness of the test machine came on indicating that there was an internal problem with my alternator. I drove with the battery light on for a month before replacing the alternator. The battery light has yet to come on with the new alternator. good luck:cool:
 
1 - 13 of 13 Posts
Top