Ford Mustang Forums banner
21 - 30 of 30 Posts

·
Registered
Joined
·
25,617 Posts
I think you are little confused

that is a DTC, not a PID, really not helpful

you need to stream data and see the start circuit PIDs
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #22 ·
I think you are little confused

that is a DTC, not a PID, really not helpful

you need to stream data and see the start circuit PIDs
Then I’m guessing I can’t do that with what I have. And I am a whole lot confused and I guess airport Ford was confused because they couldn’t fix it apologized for having it 3 days and didn’t charge me anything. With that being said this isn’t an easy thing to fix and any and all help is much appreciated. My mechanic buddy said to go get an ecu from a crown Vic that has a 4.6 automatic in it and plug it up in my stang because they don’t have pats. Any knowledge about if this will work or not? If this don’t work I found a 2000 gt convertible with engine blown for $500 that I’ll go buy and switch out every little thing I have to to make it work.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #24 ·
Correct me if I’m wrong but pats is in the cluster not the ecu.


Sent from my iPhone using Tapatalk
Not positive myself but from everything I’ve read it seems like the key chip, transponder ring which is around ignition, ecu, ecu relay, and half of the posts say cluster as well. So I just bought another identical mustang that runs if I was to change out all those parts mentioned would it definitely fix my pats issue I have?
 

·
Registered
Joined
·
25,617 Posts
Then I’m guessing I can’t do that with what I have. And I am a whole lot confused and I guess airport Ford was confused because they couldn’t fix it apologized for having it 3 days and didn’t charge me anything. With that being said this isn’t an easy thing to fix and any and all help is much appreciated. My mechanic buddy said to go get an ecu from a crown Vic that has a 4.6 automatic in it and plug it up in my stang because they don’t have pats. Any knowledge about if this will work or not? If this don’t work I found a 2000 gt convertible with engine blown for $500 that I’ll go buy and switch out every little thing I have to to make it work.

since you were not charged

take it to diagnostic shop, within 1 hr they will tell you what the issue is
 

·
Registered
Joined
·
277 Posts
I honestly don’t know but I agree with Indy take it to someone who knows what they’re doing. Pats can be a pia to work on because it’s complicated. You can turn it off in a tune but I think you still need it to work before loading the new tune.

If I had to guess I’d say the cluster and ecu are vin locked to one another so if the ecu was replaced the pats module in the cluster wouldn’t allow the car to start.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
25,617 Posts
procedure

 

·
Registered
Joined
·
677 Posts
So a locksmith made prior owner a second key and supposedly programmed it as well. That key makes theft light flash rapidly. The original Ford key makes theft light flash once pause flash twice pause etc. the car will start on ethar but not with either key. No gas to fuel rail so I thought Ford had to be the one to reprogram everything together. Well they tried that and didn’t work so they cut 2 new Ford keys and tried to program them still same outcome. Has brand new fuel pump in it but not getting fuel to rail. Dealership called me said it would take another 4 hours or so to try and figure it out and $500 with no guarantee. Why can’t they see what’s wrong with their high dollar computer? Anybody else had this same exact problem if so please please for the love of god tell me because I’m ready to crush this car. Oh and I’m calling tow company and getting my car brought back today the bill is prolly around $700 right now and can’t tell me what the problem is I’m going to have a hard time giving them one damn dollar
I had the same issue after 3 weeks it waS the fuel line that connects to the fuel rail was blocked took it off and replaced it and car started
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #29 ·
So Ford said they could not fix my issue. They tried making new keys, new transponder, and reprogramming several times and nothing. So I got my car back and did a lot of research listening to everyone’s suggestions and I decided after numerous tests to replace the whole theft system from a junkyard with all the parts being out of the same car. Key, ignition, transponder, instrument cluster, and ecu. And guess what? It worked, fired right up and purrs like a kitty. Man that was a huge relief. I want to say thanks to everyone that helped I’m not exactly sure which part I actually needed but my guess would be instrument cluster. Also the whole time the check engine light never came on at start up every other light did. I’m not really a mechanic but mechanically inclined however I suppose I’m better than the idiots at the Ford garage I took it to.
 

·
Registered
Joined
·
25,617 Posts
Isn’t rewarding, to just swap out everything, and to never know what the issue was!!

How many sets of this system did you buy from junkyard?

you know you will need backups, right?
 
21 - 30 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top