Ford Mustang Forums banner
1 - 20 of 30 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
So a locksmith made prior owner a second key and supposedly programmed it as well. That key makes theft light flash rapidly. The original Ford key makes theft light flash once pause flash twice pause etc. the car will start on ethar but not with either key. No gas to fuel rail so I thought Ford had to be the one to reprogram everything together. Well they tried that and didn’t work so they cut 2 new Ford keys and tried to program them still same outcome. Has brand new fuel pump in it but not getting fuel to rail. Dealership called me said it would take another 4 hours or so to try and figure it out and $500 with no guarantee. Why can’t they see what’s wrong with their high dollar computer? Anybody else had this same exact problem if so please please for the love of god tell me because I’m ready to crush this car. Oh and I’m calling tow company and getting my car brought back today the bill is prolly around $700 right now and can’t tell me what the problem is I’m going to have a hard time giving them one damn dollar
 

·
Registered
Joined
·
284 Posts
Check the transceiver around the key, it’s probably broken. If not check all the fuses. Could also be the pats module on the cluster, is your odometer showing up or dashes?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Odometer is showing. It only has 97,000 miles on it. Also I should prolly add it sat for quite awhile before sold to the guy I bought it from. He also thought he could get it to run but couldn’t so I bought it. However he did show me that it will run on ether so nothing on the spark side is not working I haven’t got to check injectors to see if they pulse when cranking I thought it just had to be reprogrammed at dealer and that would fix it but they haven’t got a clue yet this is the second day they have had it. I’m going after it in about an hour
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
Check the transceiver around the key, it’s probably broken. If not check all the fuses. Could also be the pats module on the cluster, is your odometer showing up or dashes?


Sent from my iPhone using Tapatalk
Sorry I’m new to this I did reply with another post but how could I find out if it’s the pats module or not? And shouldn’t the dealership be able to determine that pretty easy?
 

·
Registered
Joined
·
284 Posts
Pats disables the fuel pump but not spark so that’s why it’ll run on ether.

Can you run codes? There will be codes when the car is disabled. I don’t know if there’s a way to test the module and the transceiver is located in the steering column around the key cylinder. The only way to check it is to visually inspect it for damage.

I doubt the dealer can diagnose it easily. The literature from that era probably isn’t easy to find nowadays.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
Pats disables the fuel pump but not spark so that’s why it’ll run on ether.

Can you run codes? There will be codes when the car is disabled. I don’t know if there’s a way to test the module and the transceiver is located in the steering column around the key cylinder. The only way to check it is to visually inspect it for damage.

I doubt the dealer can diagnose it easily. The literature from that era probably isn’t easy to find nowadays.


Sent from my iPhone using Tapatalk
I can run codes but I don’t have a real expensive one it was like $100 but I did that before I sent to dealer and there are no codes and check engine light isn’t on either.
 

·
Registered
Joined
·
25,617 Posts
if anti theft is on, will be no start

need to go to ford

or buy the expensive scan tool
 

·
Registered
Joined
·
284 Posts
I can run codes but I don’t have a real expensive one it was like $100 but I did that before I sent to dealer and there are no codes and check engine light isn’t on either.
You don’t necessarily need an expensive code reader to read all codes. I use an Elm327 dongle with the Forscan app on my phone and I get pretty much all codes that are thrown.

Does the check engine light come on if you turn the key to run and leave it there? If not there’s a fault with the ecu.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
25,617 Posts
codes are not needed

need a real time scan tool

you need to see key state, see if the ecm recognizes it

i bet no
 

·
Registered
Joined
·
25,617 Posts
they might have it for another 2 weeks

doesn't mean they are on it the whole time

its very low on their priority list
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #12 ·
You don’t necessarily need an expensive code reader to read all codes. I use an Elm327 dongle with the Forscan app on my phone and I get pretty much all codes that are thrown.

Does the check engine light come on if you turn the key to run and leave it there? If not there’s a fault with the ecu.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #15 ·
Check the transceiver around the key, it’s probably broken. If not check all the fuses. Could also be the pats module on the cluster, is your odometer showing up or dashes?


Sent from my iPhone using Tapatalk
It use to show the mileage but now with the key that use to work the odometer don’t even light up
 

·
Registered
Joined
·
25,617 Posts
make sure CEL is not a bulb, your ecm may not be powered correctly if bulb is good

key run should ALWAYS have the light on the whole time key is in run

in crank, the light will go out if ecm receives rpm signal, no rpm signal means CEL will stay on in crank, and it will NOT START.

fuel in the rail is not a fuel pressure test

never use ether for a fuel test, use brake clean or carb cleaner

ether can diesel on its own without SPARK
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #18 ·
make sure CEL is not a bulb, your ecm may not be powered correctly if bulb is good

key run should ALWAYS have the light on the whole time key is in run

in crank, the light will go out if ecm receives rpm signal, no rpm signal means CEL will stay on in crank, and it will NOT START.

fuel in the rail is not a fuel pressure test

never use ether for a fuel test, use brake clean or carb cleaner

ether can diesel on its own without SPARK
So I hooked up my scan tool and pats failure is what popped up. I was told I could get an ecu from a crown Vic if it has the 4.6 engine and it won’t have pats programmed in it. Any truth to this ?
 

·
Registered
Joined
·
25,617 Posts
no idea

diagnose the failure, what PIDs are you looking at?

sounds like you are reading a DTC, that is not scan data stream, that is what you need
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top