Ford Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,084 Posts
Discussion Starter #1
Recently my 99 started bogging down at wide open throttle! I have no idea what the problem is. I swapped throttle bodies, still didn't work. It seems like its choking. Also it only does this when the motor is warmed. When I first get in it, it drives like a champ until warmed. Help me PLEASE!!!!
 

·
Registered
Joined
·
308 Posts
Sounds like a fuel problem. I just dont understand why it only does it when warm.
 

·
Registered
Joined
·
117 Posts
Joe347R6,

I had the exact problem when I changed my throttle body myself. I took it off and put it back on a few times and it still kept doing it. My cousin works at a Ford Dealership so he hooked it up the some machine did a bunch of stuff and now it doesn't do it anymore. I will see if I can find out what he did but its somthing with the computer or throttle body. Well with my car it was anyway.

Later

Kevin
 

·
Registered
Joined
·
1,084 Posts
Discussion Starter #4
The fuel pump was changed about 9 months ago. I did change out my spark plugs recently and maybe I knocked something loose or forgot to attach something. Krazy, let me know what you find out....you're the man. I am waiting to find out what is wrong and fix it ASAP because I am going to put a NOS nozzle kit on. I just want to ensure nothing serious is wrong before I spend that kind of money. Thanks guys!
 

·
Registered
Joined
·
305 Posts
Did you check/adjust the TPS voltage on the new th/body?

Dan
 

·
Registered
Joined
·
1,084 Posts
Discussion Starter #6
No I haven't. I had the 75 on there for 6 months and never had a problem. The 75 also came with the tps already attached so I assume it is set correctly. thanks
 

·
Registered
Joined
·
1,084 Posts
Discussion Starter #7
ttt
 
1 - 7 of 7 Posts
Top