Ford Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok I need your help guys..i've done everything i've known to do. So here goes: my 95 Mustang is completely stock except for a cold air intake system and I had the two catalytic converters furthest from the engine removed to make the car louder and that is it. Now heres the problem-my car would sputterwhen taking off from a complete stop but that would go away if I let go of the gas or gave it more gas. Then it would sputter around 50 mph but once again I could give it more or less gas to make it go away. So I did a tune up. Cap and rotor, plugs and wires and I changed the coil. It still had the same symptoms so merlin tried a new ignition module or something and that didn't change anything. Than just recently a friend of mine put a new distributor module in it and the symptoms changed. The ca r had a rough idle under one thousand rpm and occasionally will shut off. If I can get it above one thousand RPM than it would be fine but sputter a little bit but not nearly as bad. So idk what to do. The timing is fine and there isn't a vacuum leak..and also sometimes I can't get the car above one thousand rpm in park or drive or neural. And if I floor the pedal, the car will sputter and create no power...what shud I do guys???
 

·
Registered
Joined
·
2,773 Posts
Possible vac leak? Get a can of starter fluid and spray it near your vac hoses, throttle body, upper to lower intake with the car running. If the idle jumps up you have a leak. Also might want to buy some maf cleaner and clean it.
 
1 - 3 of 3 Posts
Top