Ford Mustang Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
1,281 Posts
Discussion Starter · #1 ·
I know some of you replied to a previous post of mine regarding these, but I still have the smell after about 400 miles. And when I hit 2nd gear, it almost feels like its slipping. Like I said before it was a straight install, no problems at all. Only thing I did diferent is took the lock washer off the bellhousing pivot ball so the the TO bearing would fit good. Other than that, it shifts fine. Is anyone having any symptoms close to that?

Mize
 

·
Registered
Joined
·
1,654 Posts
i personally don't use a SPEC cllutch..but I know a couple out here in Vegas that are using them on their F-bodies and they say that their clutch slips. I dunno?? Maybe its just something about them. :barf:
 

·
Registered
Joined
·
525 Posts
I've heard more complaints then good about these so called SPEC clutches,, my buddies acted the same way,, it would not bite,, meaning it held the power but kinda acted like it was slipping when going into gear.

Now yesterday my buddy says he just burned his up.

I know they are cheap "so called" nice clutches but I guess you get what you pay for.

I paid 1100 for my Dual Disc ALuminum setup for my car from McLeod! Hope I get what I paid for! LOL

Brad
 

·
Registered
Joined
·
320 Posts
im guesstimating 330-340 HP on my setup, on a stage 1 spec, no slippage here. maybe your clutch is adjusted too far up, its grabbing too high, that would cause it to slip because when you let off the clutch it is still being held slightly engaged
 

·
Registered
Joined
·
753 Posts
Mine has been great so far. I have a stage II with about 700 miles on it.

I have heard that the SPECs for LS1's are not so great. My LS1 buds use Cartech I believe.
 

·
Registered
Joined
·
544 Posts
i love my stage I, no slipping or anything. grabs hard
 

·
Registered
Joined
·
250 Posts
My Spec stage 2 has about 1,800 miles on it and grabs HARD,No slip.The Dual Friction it replaced is light years behind the Spec..I love mine.Street manors are great also,pedal presure is slightly stiffer than D.F....later
 

·
Registered
Joined
·
260 Posts
I have the SPEC stage III on mine and have had no smell or slipping with mine. The only issue I have had is a little chatter when I try to slip the clutch when cold.
 

·
Registered
Joined
·
1,281 Posts
Discussion Starter · #9 ·
UPDATE

I just talked to Spec. BTW, I have the stage 3 so there should be NO slipping per Spec. I think I may have found the smell. I run long tubes and I use a starter heat shield. I just looked at it and that baby is toast. It lays right on the header. I think thats it. Pete at Spec said the clutch material will not give off an oder. Now in terms of slipping, he said if, and he indicated that he had not too many have it slip, it was gonna slip it would be in the top 3rd and 4th gears. Well, mine pulls very hard in 3rd and 4th, so I think I'm just spinning the wheels. I had a pretty old clutch last year. I'm gonna try his test on the way home. I'm also gonna remove the starter shield until I get a new one. We'll see. I'll keep the board posted.

Mize
 

·
Registered
Joined
·
766 Posts
Thats cool about the clutch. You had me a little nervous, I have the stage II and have only put about 400miles on with no problems at all. Good on the street, a little stiff but I dont mind that.
 

·
Registered
Joined
·
1,281 Posts
Discussion Starter · #12 ·
Update

Well, the starter heat shield was the smell problem. I took that off. I also did the 3rd and 4th gear pulls and there is NO slip what so ever. So I may be okay.

91gt..yes my cable is right on my header. It has a shield that it lays on, but there is no other place to put the cable with long tubes. I covered it with black rubber cable protector and a thermo boot. If you know of another place i can route the cable, I'm all ears.

Mize
 

·
Registered
Joined
·
271 Posts
I'm confused where all of these complaints about SPEC clutches are? I've got a Stage 1 on my setup, and thoroughly checked over the all the boards for a concensus on this setup. I saw virtually no complaints, and I have no complaints so far.

Rest assured, though, if I have any problems at all with it I will let the board know!
 

·
Registered
Joined
·
1,554 Posts
hey i just found the tread. I am glad you have it fuigured out. Everyone who I have talked to has not had major major problems with the clutches and once they were in they were good to go. I also was going to say, the only smell I have ever smelled from a clutch was when someone burned it up not starting off right.
 
1 - 14 of 14 Posts
Top