Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
92 GT Hatch

#8 fuse continuously blows (radio, power mirrors, interior courtesy lights, engine courtesy light) after receiving the car back from the paint shop. The green w/ yellow wire is testing ground so i know that there is a grounded wire somewhere. I have eliminated any electronic component by disconnecting everything and the problem still exists. I checked the dome light area by pulling the headliner and a pillar covers and hatch latch by isolating it with a disconnect plug in the drivers rear quarter. I pulled the door pin switches also but the wire still reads ground. 95% of the interior is out so i want to rule out any door sills or seat / plastic panel pinches.

I had the front clip and passenger front fender replaced and also an aftermarket hood. Both doors and hatch stayed on the vehicle and I removed all the electronics associated with this circuit prior to taking it into the shop.

Any ideas on where else i can track the wire to look for kinks/pinches? Is there a manual out there that shows the ENTIRE electrical diagram? My chilton seems to only show the engine management. Any new ideas? I really don't want to run a new circuit for all this stuff and the door pins use a positive trigger which means i would have to rewire my alarm also...

Thanks for any input.
 

·
Registered
Joined
·
1,269 Posts
you definately have a grounded domelight or associated wire. If the dash was taken off or even losened up this can happen pretty easily. Screws can also penetrate the wires causing them to ground out. Hope this diagram helps out.

 

·
Registered
Joined
·
83 Posts
Discussion Starter #3
This schematic is exactly what i needed, Thank you. I will reply again as soon as i find the bug.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #4 (Edited)
Found the problem. Body shop managed to pinch and ground the green/yellow in the hatch lid with a nut for the spoiler. Easier fix than i thought it would be.

On a side note, anyone else trying to find a grounded wire make sure and remove ALL switches or electronics from the circuit. I forgot to unplug the light switch for the glove box. With it closed it enters ground into the system if there is no +12v on the other side of the switch. Common sense when i type this but frustrating when you think you found the problem but it is not testing right.

Thanks again for the schematic.

 

·
Registered
Joined
·
1,269 Posts
no problem, glad i could be of help. electrical issues are alwaya a PITA
 

·
Registered
Joined
·
66 Posts
Do you know what that wire is sending power too?

I've been having the same problem as you, #8 fuse keeps blowing. Looking at the Fuse Box Diagram, I didn't see anything listed for the #8 fuse that was located in the rear of the car/hatch.

Thanks!
 

·
Registered
Joined
·
66 Posts
Do you know what that wire is sending power too?

I've been having the same problem as you, #8 fuse keeps blowing. Looking at the Fuse Box Diagram, I didn't see anything listen for the #8 fuse that was located in the rear of the car/hatch.

Thanks!
 

·
Registered
Joined
·
1,269 Posts
"too?" really?
Depending on the year of your mustang, there is a hatch light that turns on at least was wired from the factory, that is supplied power from the #8 fuse.
 
1 - 8 of 8 Posts
Top