Ford Mustang Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter · #1 · (Edited)
Is anyone running 50# injectors and a stock computer with a calibrated mass air meter? How is the driveability? Any issues to be aware of? Also how much RWHP are they good for. I run a 3-core intercooler and can typically run as lean as 12:1 AF ratio on pump gas. I am running a blow-through application as well. Any suggestions for a meter? Thanks.........
 

·
Registered
Joined
·
570 Posts
I'm running 50's with a A9L & pro-M mass air, no problem's other than a little rich at idle, & sometime's have to press pedal to floor to start, driveability is good
 

·
Registered
Joined
·
974 Posts
you are lucky!!!Mine would buck really bad from take off,
and have bad idle surge!!Some work some don't..
good luck man!
 

·
Registered
Joined
·
165 Posts
Discussion Starter · #4 ·
50# injectors

Thanks for the feedback guy's. I heard the same type of thing when I got my 42#er's. I think you're probably right, some are okay and others have problem's. As for my 42's I guess I was lucky because it runs great with the stock processor, but I think they're a little on the small side. Take care!!!!!!!!!!
 

·
Registered
Joined
·
2,182 Posts
Absolutely no problems with mine.
Jim
 

·
Registered
Joined
·
2,215 Posts
Only issue I had with mine was some hot starting problems every now and then. Just held the pedal down and the car started right up.
I ran the 50's with the stock J4J1 computer ( think thats what its called ) and 42 base FP with vacuum on.


Dan
 

·
Registered
Joined
·
91 Posts
i have a novi 1000ized 306 with 6 pounds, edelbrock heads, b or x cam (not sure) cobra intake, 70 mm tb, 24 pound injectors, exhaust etc. Not sure if mass air meter was recalibrated for injectors. I also have to hold pedal to floor to start, idle surges from 900-1400 all day and shuts off constantly when rpms are low. the computer is stock. i was wondering if i need a custom chip burned for my car or could it be something else..... dont see any vacuum leaks and tb and iab are clean. could timing have anything to do with this? i need a better running car....... any answers?
 

·
Registered
Joined
·
521 Posts
I had a procharger on my car with 42's using a normal meter as a blow through and it ran like crap. I think the absolut only way they will work for u is if you get a blow through calibrated meter. The 42's worked fin on my car if I was not running a blow through but the blow through makes it go crazy.
 

·
Registered
Joined
·
570 Posts
I had the same problem before using 36's & C&L, I moved the mass air a little farther from s/c & rotated the mass air to about 10 o'clock & it ran better, but after changing to 50's & pro-m s'c calibrated I have'nt had any problems other than holding pedal to floor maybe 1 out of 10 time's at start up & when starting up when cold if I do'nt touch gas pedal I have to start it a second time to get it to keep idoling which neither is a problem for me.
 

·
Registered
Joined
·
91 Posts
i talked to somone on the phone from mustang magic, a dynotune shop in ny and they said probably the reason my idle is surging is because i dont have a boost bypass valve on the supercharger. ? he says this causes it too buck when you let off the gas but also will affect idle. this sounded strange to me because all it is basically a blowoff valve liek on a turbo, but then again mine is not there, does that sound right to you guys? the previous owner said it did not surge until he put the supercharger on. .....................
 

·
Registered
Joined
·
570 Posts
try moving the mass air farther away from supercharger, & if still surging rotate mass air to different places such as 9, 10 or 11 o'clock or maybe 1,2 or 3 oclock
 
1 - 15 of 15 Posts
Top