Ford Mustang Forums banner
1 - 20 of 135 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
I know this isn't a truck forum but its a 5.0 motor in my 92 and I'm running out of ideas.
Motor is "built" to what extent I have no idea, looks to be Heads cam intake. Still speed density.
Motor seems like its out of time. Pops out the intake now and then and in the exhaust when cranking.
I set timing and re stabbed the distributor, swapped plugs,wires, cap rotor and distributor. No change. I had it kinda running, when I pulled the plugs all but cyl 2 where soaked and black. cyl 2 looked new but wet.
New map sensor, swapped ECMs... however when I went to swap the ecm I noticed a bunch of wires cut that have no place to go and a bunch of stuff spliced together.
any ideas ?
Is there something that could have been tapped into the ecm wiring ?
 

·
Registered
Joined
·
619 Posts
Is the engine a 5.0 HO or non-HO?
 
  • Like
Reactions: 07gts197

·
Registered
Joined
·
1,352 Posts
Did you pull the spout when setting the timing?
 

·
Registered
Joined
·
7,987 Posts
It sounds like a discombobulated mess of ****.

#1, I'd check your hardware first. Do a simple compression test and see how all the cylinders are doing.

#2, If the wiring has been screwed with you'll want to locate a shop manual with wiring schematics and verify things are correct or find a new harness.

#3, HCI's don't jive well with the original speed density setups. You'll want to consider upgrading to MAF or aftermarket ECU/harness.
 

·
Registered
Joined
·
1,352 Posts
I did not, do I need to start over?
Yes, step 1 is pull the spout when doing timing. That stops the computer from messing with the timing while setting it. Your timing is definitely not correct if you set timing while the spout was installed.
 
  • Like
Reactions: HYBRED

·
Registered
Joined
·
171 Posts
Is the engine a 5.0 HO or non-HO?
This.

If the ecu is for a truck but the motor has an ho cam in it, it’ll run but not well since the firing order is different. If it has a different intake it probably has an ho with a stock non ho truck ecu. That’s if this is in a truck, it’s hard to tell from the op.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #11 ·
Yes, step 1 is pull the spout when doing timing. That stops the computer from messing with the timing while setting it. Your timing is definitely not correct if you set timing while the spout was installed.
So pull the spout and just reset to TDC? Do I need to restab the distributor? Or unplug it?
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #13 · (Edited)
Well I'm sure I have the firing order wrong. Google lead me to a 1 8 7 or something like that. Also I did not have the spout unplugged. So I'll start over later with those 2 and see if I'm getting any codes. I didn't realized the truck 5.0 was a different firing order.
Edit I was going backwards I have it 1 5 4 2 6 3 7 8
 

·
Registered
Joined
·
1,352 Posts
Unplug the spout set timing using a timing light If you can't get it to 10 degrees btdc, you'll need to restab it.
 

·
Registered
Joined
·
171 Posts
Well I'm sure I have the firing order wrong. Google lead me to a 1 8 7 or something like that. Also I did not have the spout unplugged. So I'll start over later with those 2 and see if I'm getting any codes. I didn't realized the truck 5.0 was a different firing order.
Edit I was going backwards I have it 1 5 4 2 6 3 7 8
Yes but what cam is in it?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #17 ·
Swapped plugs and Im pretty sure the wrong ones where in it. Fires now, isn't running great but is running. wont idle and seems like its just dumping fuel. I put bosh 6712s in but whatever auto lights i pulled out where twice the length. Im not sure whats correct seeing i was told it has aftermarket heads. At least it fires and the motor seems decent.
 

·
USAF retired
Joined
·
9,582 Posts
Converting to mass air should be on your list of things to do as speed density is vacuum based. How much vacuum does the engine make at idle?
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #19 ·
I'm not sure. Doesn't seem like much seeing it won't even idle. I also don't have all my tools here yet seeing we just moved and I was hoping to use the truck to get my box and such lol. I see my local pick n pull has a 95 f150 with a 5.8 so I'll be heading there this weekend to see what I can snag.
 

·
Registered
Joined
·
1,352 Posts
Until you set timing with the spout removed it's going to run like ****. I don't know why you keep changing parts when you haven't set timing correctly. Good luck...
 
1 - 20 of 135 Posts
Top