Ford Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter · #1 ·
ok i just installed my 3g alternator and i have a question. i purchased the 4 gauge cable with built in 200 amp fuse form pa performance in one of the pictures it has the 2 10 gauge wires hooked up also to the alt output. is this correct? it still seems that my car is charging on the low side, but when at 1k rpms it does not seem to get overwhelmed when i turn on accessories.

thanks
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #2 ·
search yielded all my answers. thank you corral.
 

·
Registered
Joined
·
2,542 Posts
Yes when i did mine I think that is what I did...

about it charging low...how big was your stock 2g's pulley....?

I had a 2 inch pulley on my stock 2g and on my paperformance alternator it was 2.5 inches....so in the end I almost had the same charge by the guage anywayz.

Yeah when you give it gas mine doesn't have much of a problem getting overwhelmed....its just at idle...

Alls I know is that I'm getting a 2inch overdrive pulley from ASP and maybe that will help my problem...
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #4 ·
5spd GT said:
Yes when i did mine I think that is what I did...

about it charging low...how big was your stock 2g's pulley....?

I had a 2 inch pulley on my stock 2g and on my paperformance alternator it was 2.5 inches....so in the end I almost had the same charge by the guage anywayz.

Yeah when you give it gas mine doesn't have much of a problem getting overwhelmed....its just at idle...

Alls I know is that I'm getting a 2inch overdrive pulley from ASP and maybe that will help my problem...
i have an underdrive pulley on the 2g . i just left the stock pulley on the 3g. i was looking at a ref page and it had all the parts with links to order them(can't find it now:confused: ) but yes i think a smaller one will take care of it.
 
1 - 4 of 4 Posts
Top