Ford Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Greetings everybody...it's my first post here, so hello to all!

I have a 2000 Ford Mustang Convertible with 225,000 miles. I have had her for 10 years, and in that time I've replaced the heads, redone the gaskets, replaced a clutch, power steering pump, headers, belts, hoses, air pump, and done pretty much all the regular maintenance, as well.

I also maintain my other 3 cars myself: a 1965 Thunderbird, a 1996 Escort, and a 2000 Wrangler. I am no stranger to car repairs.

It's a V6, 3.8L, and I have recently had the intake off to replace the passenger valve cover, and clean some oil buildup from the intake runners. I had it all taken apart and have reassembled it as it should be, but the last thing to do is reconnect the electrical connector that hooks up to the throttle position sensor on the throttle body.

And I can't find it. Honestly, I've looked, it's as though it's vanished. I'd be afraid it was stuck inside the valve cover or under the intake, but I don't think that's physically possible.

What I'd like help with, is for someone with a similar V6 to tell me where the heck the wires on that connector lead to, so I can trace them back to the connector and figure out where it's gone. A picture of the connection I need to connect it to is attatched.

I know it seems silly, but I've had the intake off this car at least 3 times before, and this has never happened to me. I'm really stumped.

Thanks in advance to everyone!

 

·
Registered
Joined
·
1,154 Posts
look on the wiring harness, should be around the I.A.C. plug in.......
 
1 - 4 of 4 Posts
Top