Ford Mustang Forums banner
1 - 11 of 11 Posts

· Registered
Joined
·
291 Posts
Discussion Starter · #1 ·
so, ive been getting an oddball check engine light. it comes on any old time it wants, goes out in 5 seconds or maybe 2 minutes. it never stays.

i go to autozone to get a scan, as they'll do it for free. i tell the guy at the counter its a 95, so it has to be obd I. well, he looks under the dash, and sure enough, it has the obd II port!

?

well, the obd II scan tool he was using kept reading "error". so, the tool wouldnt read.

what's my problem? do all you 95 guys have obd II ports?

confusing oddball model, that 95. new body, old engine, wierd computer...........
 

· Registered
Joined
·
823 Posts
OBD II

If i were a betting man, i'd say that your O2's are on their way out. If it were a "hard" fault (bad egr solenoid) your light would be blazing. If your car has more than 50,000 i'd replace the O2 sensors. Does you car seem to be using more gas, lately?
OBD II was first introduced (if i remember correctly) in 1995. The code scanner you'll need from Autozone is the expensice one. Wouldn't you know it. The cheapie $30 will not work.
If you pm me, i'll shoot you the testing procedures for the O2, as i don't have them here in front of me.
Hope this helps
 

· Registered
Joined
·
723 Posts
Re: No Luck pulling codes, OBD II?

timk said:
so, ive been getting an oddball check engine light. it comes on any old time it wants, goes out in 5 seconds or maybe 2 minutes. it never stays.

i go to autozone to get a scan, as they'll do it for free. i tell the guy at the counter its a 95, so it has to be obd I. well, he looks under the dash, and sure enough, it has the obd II port!

?

well, the obd II scan tool he was using kept reading "error". so, the tool wouldnt read.

what's my problem? do all you 95 guys have obd II ports?

confusing oddball model, that 95. new body, old engine, wierd computer...........
Its obviously a sensor man...your MAF would make you car run like hell...bad 02's wouldnt necassarily make you CE light come on, and again, you would feel it.

Check your EGR and IAC sensors...my IAC was busted, the CE light would come on and off but wouldnt affect the way the car ran. Same with my EGR sensor.

Later
 

· Registered
Joined
·
291 Posts
Discussion Starter · #5 ·
O2 sensors are only 2 months old. cant be them.

YES! i know that there is an eec port on the shock tower wall. that's what i was thinking he was going for. but, he went under the dash instead.

man, i tell you, its hard to get straight up info on the 95. go to buy o2 sensors...they try to sell you 4. there are only 2. ford switched computers in 96 to obd II. yet, there are obd II ports under the dash of my 95. gotta love the bastard sn95, the 94/95 cars.........

at this point, i dont care what the check engine light is flashing for. i just want to get to the bottom of the obd I/obd II controversy.

thanks for your replies, guys. ill call a ford dealer. i can get some laughs while waiting on hold for them to tell me they dont know!
 

· Registered
Joined
·
291 Posts
Discussion Starter · #6 ·
just got off the phone with a local ford tech, who was very helpful. he said the the port under the hood was not for scanning.

and here is the kicker....early 95's were obd I, later 95's were obd II. so, unless i have 2 ports under the dash, i guess mine is II, even though my build date is NOVEMBER 94!

so, going on the assumption that i have an obd II computer, what the heck does it do with the fact there are no after-cat o2's? isnt much of the information gained with an obd II computer gathered from that second set of o2's??

maybe ill just live with the intermittent light. im certainly not going to take the car to the dealer to be told i need a new cpu.
 

· Registered
Joined
·
204 Posts
I have a 94. I know for sure my car is OBD I. I got the 30$ scanner at Wal Mart and it works great with my EEC. I plug it in , by removing the cap over the plug on the side of the passenger strut tower and connecting my scanner.
I am very confident the 5.0L mustang Engines were always OBDI. In 1996 they went to the OBDII and the 4.6L engine to meet the emmissions requirements on cars and because the OBDII was required in 1996.
The guy at Schucks or wherever went under the dash, because that is where he is used to looking for OBDII ports. Be aware that alot of people who tell you things like they know what they are talking about don't really know.
Ask yourself why ford would bother to bring the computer up to OBDII when they were going to replace the engine and computer combination the next year in order to meet federal requirements?
I believe the 3.8L engine was OBDII in 94 and 95. Ford did this, because they were not going to another engine in 96 so they planned ahead to meet the federal requirements.
 

· Registered
Joined
·
3,268 Posts
Well my 94 Cobra has the port under the drivers dash.. I know I have to check codes from under the hood. If I remember correctly, don't the V-6's have the OBDII? Cause my cheap scanner says not for the V-6. That woudl be why the 5.0's have the OBDII port. Make sense to me, but not 100% sure it is correct. Anybody else.
 

· Registered
Joined
·
291 Posts
Discussion Starter · #9 ·
jrob and 94cobra pace....

you're right! the 3.8 was obd II, thats why all the cars have the obd II ports! the guy at the ford dealer is on crack, too!

the reason the under-the-dash obd II port read "error" is because it wasnt active. i have said all along that the 5.0 was obd I, i just couldnt prove it.

thanks very much for your help. im going to get a scanner tonight and do it myself.

i appreciate the help i get here on the corral.
 

· Registered
Joined
·
1 Posts
so, ive been getting an oddball check engine light. it comes on any old time it wants, goes out in 5 seconds or maybe 2 minutes. it never stays.

i go to autozone to get a scan, as they'll do it for free. i tell the guy at the counter its a 95, so it has to be obd I. well, he looks under the dash, and sure enough, it has the obd II port!

?

well, the obd II scan tool he was using kept reading "error". so, the tool wouldnt read.

what's my problem? do all you 95 guys have obd II ports?

confusing oddball model, that 95. new body, old engine, wierd computer...........
I have a 1995 Mustang 3.8l and it has a OBDll port, Pepboys was able to read the code form check engine light! Autozone told me that their readers have been upgraded and can't read below 2000!
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top