Ford Mustang Forums banner
81 - 89 of 89 Posts

· Registered
Joined
·
126 Posts
Discussion Starter · #81 ·
Let this be a lesson. Don't ever get rid of old parts thinking you don't need them because they were replaced with new. But anyway. Do that voltage drop test Dwain posted. Try another TPS. Get one from a parts yard off another vehicle.
But also what causes the idle to stay up while stopping with the clutch in it seems like it doesn’t idle down until I completely stop for a second
 

· Registered
Joined
·
2,253 Posts
But also what causes the idle to stay up while stopping with the clutch in it seems like it doesn’t idle down until I completely stop for a second
This is normal in a 5 speed car. That higher idle until the car is stopped is the feedback the ECU is receiving from the VSS sensor that the car is in motion. Once stopped the vehicle speed sensor (VSS) is not turning anymore inside the transmission and let's the ECU idle down to normal idle rpm 725-750 rpm when stopped or parked.
 

· Registered
Joined
·
2,253 Posts
Okay so I got the surging problem fixed and the car doesn’t die on my anymore now the idle is high and the throttle sticks a little bit and I have to kick it hard to get it to start moving
Remove the throttle cable off the ball end of the linkage on the bottom of throttle body and manually try to move the linkage back and fourth to open and close the throttle blade and see if it feels smooth opening and closing. If it is then lube the throttle cable. I use graphite and apply it to the area around the return spring. Can show you where I apply it tomorrow. Sometimes they dry out there and start sticking.
 

· Registered
Joined
·
126 Posts
Discussion Starter · #84 ·
Remove the throttle cable off the ball end of the linkage on the bottom of throttle body and manually try to move the linkage back and fourth to open and close the throttle blade and see if it feels smooth opening and closing. If it is then lube the throttle cable. I use graphite and apply it to the area around the return spring. Can show you where I apply it tomorrow. Sometimes they dry out there and start sticking.
I fixed my issues my car now runs perfect I had a weird box plugged in to my tps I took it out and plugged it directly into the harness and now car runs amazing
 
81 - 89 of 89 Posts
Top